Chat now with support
Chat with Support

Foglight 5.9.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrading the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploying an agent package using the browser interface

Upgrade Foglight for VMware

The latest version of Foglight for VMware is 5.8.0.

Foglight for VMware 5.8.0 requires Management Server version 5.9.5, or Foglight Evolve 9.0.

Upgrades are supported from Foglight for VMware 5.6.15.x and later. Upgrades from the versions earlier than 5.6.15.x are not supported.

Important: The VMware Performance Agent uses a Virtual Center account to log in to the monitored Virtual Center. The administrative role associated with that account must be granted the Performance > Modify intervals privilege. When collecting traffic-type network metrics from the monitored ESX hosts, this privilege enables the VMware Performance Agent to change the performance metric counter levels in order to collect this data. On the Virtual Center server, verify that the user has the following privileges:

4
Important. If you increased the JVM memory allocation in a previous cartridge installation (as described in the “System Requirements” section of the Foglight for VMware Release Notes), you need to repeat this process after deploying the new agent package and before activating the agents.

Upgrade Foglight for VMware Horizon View

The latest version of Foglight for VMware Horizon View is 5.8.0.

Foglight for VMware Horizon View 5.8.0 requires Management Server version 5.9.5 or Foglight Evolve 9.0. It also requires Foglight for VMware 5.8.0 (or later) to be installed and enabled on the same Foglight Management Server.

1
On the Cartridge Inventory dashboard, install the following cartridge files. Do not remove the older version of these cartridges. Install the new versions over the older versions. The sequence of cartridge installation is important because of their dependencies.
2
On the navigation panel, under Dashboards, click VMware View to open the VMware View Environment dashboard.
3
Click the Administration tab.
4
Click Update Agent once for each Foglight Agent Manager instance on which outdated VMware Horizon View agents are running.
5
Click the Details tab, then the Desktops tile.
a
On the navigation panel, click Administration > Agents > Agent Status, to open the Agent Status dashboard.
c
Click Modify the private properties for this agent.
d
In the Properties area, set to True the following options: Collect CPU metrics, Collect disk metrics, Collect memory metrics, and Collect network metrics.
e
Click Save.

Upgrade Foglight for Citrix XenDesktop and XenApp

The latest version of Foglight for Citrix XenDesktop and XenApp is 5.8.0.

Foglight for Citrix XenDesktop and XenApp 5.8.0 requires Management Server version 5.9.5, or Foglight Evolve 9.0.

Foglight for VMware version 5.8.0 (which includes the DRP-5_8_0.car, Virtual-VMware-5_8_0.car, and Virtual-VMware-Admin-5_8_0.car cartridge files)
NOTE: After installing the Virtual-VMware-5_8_0.car cartridge, existing vCenter agents (VC agents) must be updated using the Update Agent button in the VMware Environment > Administration tab.

 

Upgrade the Integration cartridges

Follow the procedure in this section to upgrade an earlier version of an integration cartridge to the latest version. For details, refer to the following topics:

Related Documents