Chat now with support
Chat with Support

Foglight 5.9.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrading the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploying an agent package using the browser interface

Upgrade the Application Performance Monitoring cartridges

For details, refer to these topics:

Upgrade Foglight for Application Operations

Foglight for Application Operations has been updated to version 5.9.8.5. Upgrades from version 5.9.x, 5.7.x, and 5.6.4.x are supported.

Starting from Foglight for Application Operations 5.9.8.4, Foglight for Application Operations must be installed on a running Foglight Management Server 5.7.5 or later.

Foglight Agent Managers of version 5.7.0 or later must be installed on all the hosts that you want to use for local or remote monitoring.

Installing this cartridge also upgrades the following cartridges to the following versions:

For a complete list of cartridges included in Foglight for Application Operations, see the Foglight for Application Operations Release Notes.

Install Foglight for Application Operations 5.9.8.5 (Application-Operations-5_9_8_5.car) as you would install a new cartridge. Do not delete the previous version of the Cartridge for Dependency Mapping or Foglight for Application Operations.

For detailed cartridge installation instructions, see “Installing Foglight Cartridges” in the Foglight Administration and Configuration Help.

Upgrade Foglight for Java EE Technologies

The latest version of Foglight for Java EE Technologies is version 5.9.13. Upgrades from versions 5.9.x and 5.8.x are supported.

Foglight for Java EE Technologies 5.9.13 requires Management Server version 5.9.x.

The Nexus requires Foglight Agent Manager version 5.6.7.2 or later. Version 5.6.7.3 or later is recommended. The Java EE Integration Agent requires Foglight Agent Manager version 5.6.2.2 or later.

Foglight for Java EE Technologies version 5.9.13 accepts connections from the JavaEE Agent versions 5.9.x and 5.8.x. Connections from version 5.7.x, 5.6.1, or earlier of the JavaEE Agent are not supported.

Upgrade Foglight for Java EE Technologies from version 5.9.x to version 5.9.13

1
Install the 5.9.13 cartridge (ApplicationServers-Java-5_9_13.car) as you would a new cartridge. Do not delete or uninstall the previous version. For cartridge installation instructions, see “Installing Foglight cartridges” in the Foglight Administration and Configuration Help.
2
On the navigation panel, under Dashboards, click Application Servers > Administration > Application Servers Administration.
e
A task is added to the Task History list at the bottom of the view. Check the Result column for information on the upgrade process and its status.
Related Documents