Chat now with support
Chat with Support

Foglight 5.9.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrading the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploying an agent package using the browser interface

Upgrade Foglight for Microsoft .NET from version 5.9.x

1
Install the 5.9.12 cartridge (ApplicationServers-DotNET-5_9_12.car) as you would install a new cartridge. Do not delete or uninstall the previous version. For cartridge installation instructions, see “Installing Foglight cartridges” in the Foglight Administration and Configuration Help.
a
On the navigation panel, under Dashboards, click Application Servers > Administration > Application Servers Administration.
f
A task is added to the Task History list at the bottom of the view. Check the Result column for information on the upgrade process and its status.

Configuration migration during upgrades

If you have modified the configuration files and you perform a minor version upgrade (for example from x.y.z to x.y.z+1), your modified files are preserved. The default contents of the configuration files from the new version are overwritten with your changes.

For example, you have version 5.9.3.2 currently installed and you have modified the Nexus recording.config and the .NET agent instrumentation.config. Upgrading to version 5.9.12 would overwrite the default contents of the 5.9.10 versions of those files with your file contents from 5.9.3.2. All other 5.9.12 configuration files are unchanged, and contain the default contents installed by the 5.9.12 cartridge.

NOTE: Configuration files managed through the Advanced dashboards (for example, nexus/aggregation.config) are not automatically migrated. If you have made any modifications to these files, they must be migrated manually, with the assistance of Customer Support where necessary.
In addition, the nexus/compatible-builds.config file is never automatically migrated. If you have any patch build IDs, these must be manually added to the new version’s compatible-builds.config with the assistance of Customer Support.

Upgrade the cartridge from version 5.6.x to version 5.9.x

2
Use the Agent Setup wizard (Application Servers > Administration > Application Server Administration dashboard) to create a new installation. Creating the installation will upgrade the existing agents.

Upgrade Foglight for IBM WebSphere MQ Server

The latest version of Foglight for IBM WebSphere MQ Server is 5.5.5.13.

Foglight for IBM WebSphere MQ Server 5.5.5.13 requires Management Server version 5.6.5 or later.

1
From the Agent Status dashboard (Administration > Agents > Agent Status), select and deactivate all MQAgent instances.
2
Install the 5.5.5.13 cartridge (MQ-5_5_5_13.car) on the Management Server. For cartridge installation instructions, see “Installing Foglight cartridges” in the Foglight Administration and Configuration Help.

 

Related Documents