Chat now with support
Chat with Support

Foglight 5.9.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrading the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploying an agent package using the browser interface

Upgrade the Database cartridges

This section explains how to upgrade an earlier version of a database monitoring cartridge to the latest version. For details, refer to the following topics:

Upgrade Foglight for DB2 LUW

The latest version of Foglight for DB2 LUW is 5.9.4.10, which requires Management Server version 5.9.2 (or later) and Agent Manager version 5.9.2 (or later).

For complete cartridge upgrade and installation instructions, see the Foglight for DB2 LUW User and Reference Guide.

The Foglight for Infrastructure agent is not created in the following scenarios:

Upgrade Foglight for Oracle

The latest version of Foglight for Oracle is 5.9.4.10. Direct upgrades to Foglight for Oracle 5.9.4.10 are supported from versions 5.7.5.x and later.

Foglight for Oracle 5.9.4.10 requires Management Server version 5.9.2 or later and Agent Manager version 5.9.2 or later.

The Foglight for Infrastructure agent is not created in the following scenarios:

For cartridge installation instructions, see the Foglight for Databases Deployment Guide.

Once you have upgraded the cartridge, to deploy the agent package, navigate to the Global View dashboard and follow the upgrade wizard instructions. For a procedure describing how to deploy the agent package, see the Foglight for Oracle User Guide.

Upgrade Foglight for SQL Server

The latest version of Foglight for SQL Server is 5.9.4.10.

A direct upgrade to Foglight for SQL Server 5.9.4.10 is only available from version 5.7.5.x or later. Customers that are running earlier versions of the product must first upgrade to version 5.7.5.x and then upgrade to version 5.9.4.10.

Foglight for SQL Server 5.9.4.10 requires Management Server version 5.9.2 (or later) and Agent Manager version 5.9.2 (or later).

For cartridge installation instructions, see the Foglight for Databases Deployment Guide.

Once you have upgraded the cartridge, to deploy the agent package, navigate to the Global View dashboard and follow the upgrade wizard instructions. For a procedure describing how to deploy the agent package, see the Foglight for SQL Server User Guide.

Related Documents