Chat now with support
Chat com o suporte

Rapid Recovery 6.3 - Installation and Upgrade Guide

Overview and System Requirements Installing Rapid Recovery Upgrading Rapid Recovery Managing Rapid Recovery licenses

Consider localization before upgrading

Rapid Recovery release 6.3 is an international release. In addition to availability in English, this release is localized into simplified Chinese, French, Korean, German, Japanese, Brazilian Portuguese, and international Spanish. When a localized version is installed, you can see or change the current display language set for the Core Console in the general settings for the Core.

To change these settings, see "Configuring Core general settings" in the Rapid Recovery 6.3 User Guide.

Rapid Recovery beta program considerations

Customers who participated in the Rapid Recovery beta program did so with the requirement that the beta software be installed in a lab environment, not a production environment. There is no direct upgrade path from a beta release to the generally available release. Interoperability of beta releases and production releases is not supported.

If you participated in the beta program, do not attempt to upgrade the beta version of the Rapid Recovery Core. Instead, if using the same server, perform the following steps:

  • Delete your repository or repositories.
  • Perform a full uninstall of the Rapid Recovery Core using the installer or from Control Panels, Add/Remove.
  • Obtain the production version of the Core installer or Core web installer and perform a clean install of the Core.

    For more information about downloading Rapid Recovery software, see Obtaining Rapid Recovery software.

Upgrading AppAssure 5.x Core to Rapid Recovery Core

To install the latest version of Rapid Recovery, download the installers as described in the topic Obtaining Rapid Recovery software.

NOTE: Quest recommends retaining the binary installer file for any currently installed Rapid Recovery software product. You can use this file in the future to reinstall, repair, or remove the software.

Quest Software Inc. policy is to support the current release, plus the latest maintenance release of the two prior major or minor software releases. For specific information on full, limited, or discontinued support, see the Product Life Cycle and Policies tab from our Support website at https://support.quest.com/rapid-recovery/.

If upgrading from any version of AppAssure, also read the next subsection, Upgrading from AppAssure.

When upgrading from any version of Rapid Recovery to release 6.2, you can perform an in-place upgrade. Always upgrade the Core before upgrading protected machines. If using replication, upgrade target Cores before source Cores.

When upgrading the Core (or when upgrading the Agent software on Windows machines) from AppAssure Agent 5.4.3 or Rapid Recovery Agent release 6.x, you can install the new version without removing the old version. If you want to upgrade a version older than 5.4.3, best practice is to first upgrade to release 5.4.3. You can then run the installer for the new Agent software.

Upgrading from AppAssure Core

Before upgrading the AppAssure Core to Rapid Recovery Core, verify if you have any custom binary patches applied, and note the patches used. On the Core machine, access the Programs and Features control panel, and take note of any custom binaries (identified by the letter P, a dash and six digits; for example, P-000678). Having this list accessible can increase the ability of Quest Data Protection Support to assist you in the event of upgrading difficulties.

Keep in mind the following:

  • If upgrading from AppAssure Core 5.2.x to Rapid Recovery Core, you must use a three-step process. First, upgrade to AppAssure Core 5.3.7. Then upgrade to AppAssure Core release 5.4.3. Finally, upgrade to Rapid Recovery Core release 6.3.
  • If you want to upgrade from AppAssure Core 5.3.x, 5.4.1, or 5.4.2, best practice is to perform a two-step upgrade process. The first step is to upgrade to AppAssure Core 5.4.3. As the second step, run the Rapid Recovery release 6.3 installer as in-place upgrade for the Core and Agent components, respectively.
  • If upgrading from AppAssure Core 5.4.3 to Rapid Recovery Core release 6.3, you can obtain the new Rapid Recovery Core release 6.3 installer, and run it on your 5.4.3 Core as an in-place upgrade. You can also perform in-place upgrades from AppAssure Agent release 5.4.3 to Rapid Recovery Agent on Windows machines.

NOTE: Due to legal divestiture agreements between Dell and Quest, only rebranded versions of Rapid Recovery documentation and software (release 6.1.2 and later) can be downloaded from the technical documentation website and the Quest support website, respectively. If you have not retained the installer, Quest cannot provide it. In such cases, uninstall the earlier software version.

 

Caution: Before uninstalling AppAssure Agent, make sure the protected machine backs up to the Core. When you see the option to Uninstall the configuration settings and data, including all backup images and change logs, clear the option. You must retain settings and data. Then, perform a clean install of a supported Rapid Recovery version on the same machine.

In all cases, before upgrading the version of the Agent software on protected machines, verify that the operating system on each relevant machine is still supported. For supported operating systems, refer to the Rapid Recovery .

When upgrading the Agent software on Linux machines from any AppAssure release to Rapid Recovery Agent, first remove the old Agent software version. When removing AppAssure Agent on Linux machines, the preferred process is to use the shell script in the original installer. However, a process is included to manually remove the Agent if necessary. For more information, see Uninstalling the AppAssure Agent software from a Linux machine.

Then, perform a clean install of Rapid Recovery Agent. When upgrading the Agent software on Linux machines from Rapid Recovery Agent release 6.0.1 or later, you can use the appropriate package manager for your distribution of Linux. For more information, see Uninstalling the Rapid Recovery Agent software from a Linux machine. You may need to remove the local software repository. This requirement is included in upgrading steps.

Additionally, be aware of the following information when upgrading from AppAssure 5.3.x and later:

  • Recovery points are represented differently in AppAssure release 5.4.x and later, as part of the changes made to improve application performance. When upgrading from AppAssure 5.3.x to AppAssure 5.4.x, existing recovery points are converted to the new representation, which is not backward-compatible. You cannot downgrade an AppAssure release 5.4.x installation to 5.3 (or a Rapid Recovery release) unless you recreate your repository.
  • When launching the Core for the first time after upgrading from versions prior to Rapid Recovery 5.4.1, the conversion of existing recovery points will take approximately twice as long as loading the same recovery points under previous versions. After this initial conversion, however, loading recovery points will be significantly faster than with previous versions.

    NOTE: When upgrading from AppAssure 5.3.x to 5.4.x, ensure that you factor extra time for converting recovery points into your planning before your upgraded environment is ready for use. .

  • After upgrading from versions prior to Rapid Recovery 5.4.1, if you attempt to set up a retention policy on a replicated target Core that differs from the replication policy on the source Core, you will first be prompted to perform a repository Integrity Check Job. The same requirement applies if you want to set up a custom retention policy for a replicated agent. Running this job can preemptively identify inconsistencies in replicated recovery points, providing the opportunity to replace those with error-free recovery points.

    Caution: Running the Integrity Check Job is expected to take an extended period of time. The time required differs for each environment, based on the quantity and type of data in your repository and also based on the underlying storage system. While the job is running, no other transactions can be performed in that repository, including transfers (snapshot and base image backups, and replication), nightly jobs, and so on. Ensure that you factor extra time for completing a lengthy Integrity Check Job into your planning if these situations apply to you.

Upgrading steps overview

This topic provides an overview for upgrading your AppAssure or Rapid Recovery Core environment from an earlier version to release 6.3. When this topic contains links to other tasks, view those topics before proceeding.

 

NOTE: If upgrading your Core from a version earlier than AppAssure version 5.4.3, please first upgrade the Core to release 5.4.3.

When upgrading AppAssure to Rapid Recovery, perform the following steps:

  1. Review upgrading factors such as compatibility, replication scenarios, and best practices as described in this document. Factors include the following:
    Review the operating system of the Core machine and any machines you want to protect. For more information about system requirements, see the Rapid Recovery 6.3 System Requirements Guide.
    Ensure the Core you want to upgrade is sized appropriately. For guidance on sizing your hardware, software, memory, storage, and network requirements, see knowledge base article 185962, “Sizing Rapid Recovery Deployments."
    If using replication, be sure to follow the order of operations for upgrading described in the topic Upgrading factors to consider.
  2. If using a standard phone-home license or a trial license, verify that your Cores can contact the Rapid Recovery License Portal. The UI may differ slightly based on the version of Core you are using, but the following is a guideline:
    1. Navigate to the Rapid Recovery Core Console.
    2. On the icon bar, click [Settings]Settings and then select Licensing.
    3. Scroll down to the License Server pane and click Contact Now.
      After a brief pause, you can briefly see a message indicating that the license server was contacted.
  3. Download the Rapid Recovery Core installer program (full installer or web installer, as applicable), but do not launch it yet. If you see a notification on the Core Console for an automatic update, you can click the link to download the installer. For more software download options, see Obtaining Rapid Recovery software.
  4. Review the topic Upgrading AppAssure 5.x Core to Rapid Recovery Core to determine whether you are eligible to upgrade in place.
  5. For each Core you want to upgrade, pause and disable all data transfer activities, including replication, snapshots, and nightly jobs. Doing so expedites the Core Service shut-down process during the upgrade. For specific details, see Preparing the Core server to upgrade.
  6. Run the installer programs on each Core you want to upgrade. If using replication, be sure to follow the upgrade order described in the topic Upgrading factors to consider. For specific instructions on using the Core installer, see Installing the Rapid Recovery Core.
  7. After you install the Core software, launch the Rapid Recovery Core Console. If upgrading from a trial version, or if prompted to enter a license key, ensure your Rapid Recovery software license is accessible to the Core server. Then, associate license keys on each Core as appropriate. For more information, see the topic Updating or changing a license.
  8. Optionally, if you want to take advantage of the latest Agent features, verify that the OS on each protected machine is supported, and then upgrade the Rapid Recovery Agent software. Keep in mind the following:
    • For various options for obtaining and deploying Rapid Recovery Agent, see the topic Obtaining Rapid Recovery software.
    • For Rapid Recovery version 6.2.1, Direct upgrade of Rapid Recovery Agent is supported from release 5.4.3 and later to release 6.2.1. If upgrading to release 6.3, you can upgrade to release 6.2.1 and then from 6.2.1 to release 6.3x. For more information, see the topic Upgrading AppAssure 5.x Core to Rapid Recovery Core.
    • You can also protect machines agentlessly using Rapid Snap for Virtual. For more information, see the Rapid Recovery 6.3 User Guide topic "Understanding Rapid Snap for Virtual."
  9. As a best practice, restart all machines on which you installed or upgraded the Agent software.

    Restarting ensures that the Agent service is running, and that proper kernel module is used to protect the machine, if relevant.

  10. If using agentless protection in release 6.2x and later, associate each guest VM with its protected hypervisor host to reduce the consumption of licenses from your Enterprise license pool. For instructions, see step 3 in the Rapid Recovery 6.3 User Guide topic "Viewing and modifying protected machine settings."
  11. As a best practice, after making changes that affect licensing or after applying a new license on your Core, you should refresh the Core's association with the license server as described in step 2 above.
    The Core reaches the license portal and refreshes information accordingly.
Documentos relacionados