Chat now with support
Chat with Support

We are currently experiencing issues on our phone support and are working diligently to restore services. For support, please sign in and create a case or email supportadmin@quest.com for assistance

Foglight 5.9.2 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrading the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploying an agent package using the browser interface

Upgrade Foglight for OpenStack

The latest version of Foglight for OpenStack is 5.7.4.

Foglight for OpenStack 5.7.4 requires Management Server version 5.9.x, or Foglight for Virtualization, Enterprise Edition 8.7.

Install Foglight for OpenStack version 5.7.4 (OpenStack-5_7_4.car) as you would install a new cartridge. Do not delete the older version of the .car file. Install version 5.7.4 over the older version.

Upgrade Foglight for PowerVM

The latest version of Foglight for PowerVM is 5.9.2.

Foglight for PowerVM 5.9.2 requires Management Server version 5.9.x. Foglight Agent Manager 5.9.x must be installed on all the hosts that you want to use for local or remote monitoring.

3
Install Foglight for Infrastructure version 5.9.2 (Infrastructure-5_9_1.car) on the Management Server as you would install a new cartridge. Do not uninstall or delete the previous version of this file. For complete instructions, see “Installing Foglight cartridges” in the Foglight Administration and Configuration Help.
When installing the Infrastructure-5_9_1.car file, the following cartridges are added to the Cartridge Inventory:

Upgrade Foglight Resource Optimizer

The latest version of Foglight Resource Optimizer is 5.7.4.

Foglight Resource Optimizer 5.7.4 Management Server version 5.9.x, or Foglight for Virtualization, Enterprise Edition 8.7.

Foglight Resource Optimizer for VMware Environments also requires Foglight for VMware version 5.7.4.

Foglight Resource Optimizer for Hyper-V Environments also requires Foglight for Hyper-V version 5.7.4.

NOTE: When upgrading VMware-Optimizer-5_6_16_1.car to version 5.7.0 (or later), follow one of these processes:
Upgrade the VMware-Optimizer-5_7_4.car before upgrading Optimizer-5.7.4 car.
Disable VMware-Optimizer-5_6_16_1.car before upgrading to Optimizer-5_7_4.car and VMware-Optimizer-5_7_4.car.
Foglight for VMware version 5.7.4 (which includes the DRP-5_7_4.car, Virtual-VMware-5_7_4.car and Virtual-VMware-Admin-5_7_4.car cartridge files)
Foglight Resource Optimizer version 5.7.4 (which includes the CommonAnalytics-5_7_4.car, DRP-5_7_4.car, Optimizer-5_7_4.car, and VMware-Optimizer-5_7_3.car cartridge files)
NOTE: After installing the Virtual-VMware-5_7_4.car cartridge, existing vCenter agents (VC agents) must be updated using the Update Agent button in the VMware Environment > Administration tab.
3
If configuration has been previously edited to support larger environments, refer to Foglight for VMware Release Notes to restore the configuration.
Foglight for Hyper-V version 5.7.4 (which includes the DRP-5_7_4.car, Virtual-HyperV-5_7_4.car, and Virtual-HyperV-Admin-5_7_4.car cartridge files)
Foglight Resource Optimizer version 5.7.4 (which includes the CommonAnalytics-5_7_4.car, DRP-5_7_4.car, Optimizer-5_7_4.car, and HyperV-Optimizer-5_7_4.car cartridge files)
NOTE: After installing the Virtual-HyperV-5_7_4.car cartridge, existing HyperV agents must be updated using the Update Agent button in the HyperV Environment > Administration tab.

Upgrade Foglight for SNMP

The latest version of Foglight for SNMP is 5.9.2.

Foglight for SNMP 5.9.2 requires Management Server version 5.7.5 or later. It also requires Foglight for Infrastructure 5.8.5.4 or later.

Upgrades are supported from Foglight for SNMP 5.8.5 and later. Upgrades from previous SNMP-related Foglight solutions are not supported.

Prerequisite: Foglight for Infrastructure 5.9.2 must be installed before upgrading to Foglight for SNMP 5.9.2.

IMPORTANT: The BindUpTimeToHostBootTime rule was updated for this release. Before upgrading Foglight for SNMP to version 5.9.2, ensure that the BindUpTimeToHostBootTime rule was not modified on your environment. After upgrading to version 5.9.2, you must disable the GenericSNMPService cartridge and then re-enable it (or restart the Management Server), so that the rule change takes effect.
1
Use the Administration > Cartridges > Cartridge Inventory dashboard to install the SNMPCartridge-5_9_1.car cartridge and all the sub-cartridges within it. Do not delete the older version of the .car file. Install version 5.9.2 over the older version.
a
Navigate to the Administration > Agents > Agent Status dashboard.
Select any GenericSNMPAgent type agent and any GenericSNMPTrapAgent type agent and click Upgrade.
Click Deploy Agent Package and deploy both GenericeSNMPAgent and GenericSNMPTrapAgent packages to the targeted Foglight Agent Manager host.
3
Disable the GenericSNMPService cartridge and then re-enable it (or restart the Management Server), so that the rule changes takes effect.
Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating