The information in this article applies to:
File System Auditor Version 2.x and higher
SYMPTOM:
After configuring File System Auditor you may find that no information is getting written to the database, and there may be a number of errors in the application event log on the File System Auditor server with Event ID: 107, “Error opening cache file”:
![[image]](https://support.quest.com/KBArticleImages/SL3856/646926f5.jpg)
CAUSE:
On the agent machine getting the Event ID 107 errors, go to the File System Auditor installation directory (default location is %Program Files%\ScriptLogic Corporation\File System Auditor\Agent). There will be a number of FSA####.tmp files which indicate that the program is gathering auditing events, but unable to write them to the database.
The root cause of this problem is related to insufficient privileges to the File System Auditor installation directory. The account granted as the Set Database Logon Account must have permissions to this location in order to move the temp files out of the installation directory location and write them to the database.
RESOLUTION:
Check the NTFS permissions on the File System Auditor installation directory where the temp files are stored, and ensure that the user account you have configured to access the database has permissions to access this folder.
For Windows authentication, the account used to install the agent should be in the Local Administrators Group on the Agent machine and in the FSA_Admin group. This group is either local on the SQL server, or global in Active Directory Users folder, depending on what was selected when the database was created.