Chat now with support
Chat with Support

Foglight for Azure SQL Database (Cartridge) 5.9.5.20 - Release Notes

Resolved issues and enhancements

Resolved issues and enhancements

The following is a list of issues addressed and enhancements implemented in this release.

Defect ID

Resolved Issue

AZFOG-28

Fixed an issue that due to script errors, failed to change the RMI port configuration.

AZFOG-25

Fixed an issue that Azure cartridge rule SQL_AZURE-EmailNotification_Rule_General and Oracle cartridge rule DBO-EmailNotification_Rule_General have the same ID.

AZFOG-16

Fixed an issue that the blocked process count does not match on blocking dashboard.

AZFOG-8

Fixed an issue that FileNotFoundException occurs in Azure SQL DB agent log.

AZFOG-4

Fixed an issue that the severity icon and unit of Query Store Utilization are not showing up for a fresh monitored instance.

FOGDG-1323

Fixed an issue that the potential email notification string combination is incorrect.

 


Known issues

Known issues

The following is a list of issues known to exist at the time of this release.

 

Defect ID

Known Issue

AZFOG-29

When accessing the Database dashboard, no entry to the Upgrade wizard can be found after new version cartridge has been  installed.
Workaround: Upgrade agent on Agent Status dashboard.

SSFOG-1569

User Level Access and Manage Alarm Blackouts are not supported for 5.9.5.10 Azure SQL DB, and they are not UI limitation/notes.

SSFOG-1629

Azure cannot change RMI setting in Administration.
Workaround: Refer to KB: https://support.quest.com/zh-cn/foglight/kb/312636/cannot-update-rmi-for-azure-sql-agent

GVFOG-207

An error log showed in FMS log for loading heatmap component in FMS version before 5.9.3.

n/a

Cross platform report is not supported for Azure SQL DB.

n/a

Agent does not support MFA (Multi-Factor_Authentication) connections to Azure databases.


Third party known issues

The following is a list of third party issues known to exist at the time of this release.

 

Defect ID

Known Issue

FOGDG-650

The Foglight Agent Manager (FglAM) failed to restart when upgrading DB Cartridge, which is due to "Could not obtain a deployment lock" error.

Workaround: Perform the procedure described in the Knowledge Article 266110.

FOGDG-1372

Cannot use AD account to monitor Azure SQL DB when the FglAM deploy in Azure VM.
Workaround: Upgrade DataDirect driver to version 6.0.

n/a

The Windows System Center Endpoint Protection (SCEP) tool and Anti-Virus Protection tools installed on Windows® may negatively impact CPU and system performance of machines running Foglight, Foglight  Agent Manager, and the SQL PI repository.
To reduce resource consumption it is highly recommended that you exclude the following directory from being scanned by the protection tools:

  • <installation directory>:\Quest\<FoglightAgentManager>

n/a

Anti-virus software may negatively impact the CPU and system performance of machines running Foglight. To reduce resource consumption, it is highly recommended to exclude the relevant directory, processes, and executables from being scanned by the anti-virus software. For detailed information, refer to the "Configuring anti-virus exclusion settings" in Installing Foglight on Windows with an Embedded PostgreSQL Database.

n/a

The Foglight Time Bar Chart click event does not work with Chrome version 40.x.x.x and 39.x.x.x. https://code.google.com/p/chromium/issues/detail?id=428308

 

 


Upgrade and compatibility

Upgrade and compatibility

The following Foglight product versions and platforms are compatible with this release.

Product Name

Product Version

Platform

Foglight Management Server

5.9.2

5.9.3

5.9.4

5.9.5

5.9.7

All platforms supported by these versions of the Foglight Management Server

Foglight Agent Manager

Note: The monitoring agents available in this version of Foglight for Azure SQL Database support the Agent Manager HA failover mode, except for the Agent Manager monitoring SQL PI agents. For more information about this mode, see the Agent Manager Guide.

5.9.2

5.9.3

5.9.4

5.9.5

5.9.7

All platforms supported by these versions of the Foglight Agent Manager

 

Note: Foglight for Azure SQL Database 5.9.5.20 is compatible with Foglight 5.9.7, however, it cannot run on Foglight 5.9.7 with FIPS-compliant mode enabled.

 


System requirements

System requirements

Before installing Foglight for Azure SQL Database, ensure that your system meets the hardware and software requirements detailed in Foglight System Requirements and Platform Support Guide. Customers running large deployments (more than 20 agents) should consult the Foglight for Databases Deployment Guide.

Required privileges

For information on the required privileges, refer to the Foglight for Databases Deployment Guide.

Supported Platforms

  • Microsoft SQL Azure V12

 

Final Browser Support Notice

Support for Microsoft® Internet Explorer® 8, 9, and 10 has been discontinued in this Foglight release.

Microsoft ended the support for these browsers on January 12, 2016. For more information, visit https://support.microsoft.com/en-us/lifecycle?p1=13418.

 


Related Documents