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Agent goes offline and transfer fails due to WMI Quota error
Description
The backups work for a few days then start failing with the WMI error: "Unknown WMI error: "Quota violation WMI Query: SELECT * FROM Win32_OperatingSystem -namespace root\cimv2"
Cause
WMI memory quota limitation
Resolution
To resolve the issue please perform these steps:
Go to Start–> run and type wbemtest.exe in "Run as admin" mode
Click Connect on the Windows Management Instrumentation Tester
In the namespace text box just enter "root" (without quotes)
Click Connect Note: you aren’t connecting to CimV2 or any other namespaces. It’s ROOT
Click "Enum Instances…"
In the Class Info dialog box enter Superclass Name as "__providerhostquotaonfiguration" (without quotes) and press OK.
A query Result window will come up. In this windows now double click "__ProviderHostQuotaConfiguration=@"
An Object Editor windows will come up now
Under properties find the property "MemoryPerHost" or any other ones you need to modify and double click it
Change the value to 1024 MB which is 1073741824
Click Save Property
Click Save Object in the Object Editor window
Close the other windows now and exit WMI Tester
Restart the agent server
If the issue still persists, please increase both MemoryAllHosts and MemoryPerHost values to 4294967296
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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