Chat now with support
与支持团队交流

Foglight 5.9.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrading the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploying an agent package using the browser interface

Understand product versions

This guide provides instructions on how to upgrade to the latest version of the Foglight® Management Server and the Foglight Agent Manager. This guide also provides upgrade instructions for the cartridges and cartridge-related components that are included with Foglight 5.9.x. The latest version of the Foglight Management Server is 5.9.5.

This section provides information about important changes made in this release, product versions, and components compatibility:

Components compatibility

The Foglight 5.9.x code line includes a number of critical changes which require particular attention for customers upgrading from a 5.7.x version. Specifically, three primary functional capabilities (server side data handling, Federation, High Availability) that used legacy JBoss components in versions prior to 5.9.x have been re-written to improve Foglight Management Server security. This has the following specific impacts on customers upgrading from a 5.7.x version.

Compatible cartridges list

If the following cartridges are installed on your Management Server, you will need to upgrade them to a version compatible with Management Server 5.9.x before upgrading the Management Server.

Foglight for VMware: must be upgraded to 5.7.3 or higher
Foglight for DB2 LUW: must be upgraded to 5.7.5.41 or higher
Foglight for SQL Server: must be upgraded to 5.7.5.41 or higher
Foglight for Sybase: must be upgraded to 5.7.5.40 or higher
Foglight for Oracle: must be upgraded to 5.7.5.41 or higher
Foglight for Application Operations: must be upgraded to 5.9.8.5 or higher
Foglight for Microsoft .NET: must be upgraded to 5.9.12 or higher
Foglight for Java EE Technologies: must be upgraded to 5.9.12 or higher
Foglight ActionPacks: must be upgraded to 5.6.3.5 or higher
Foglight for Automation: must be upgraded to 5.6.3.5 or higher
Foglight APM for End User Experience: must be upgraded to 5.9.11.1 or higher
Foglight for Transaction Recorder and Player: must be upgraded to 5.6.13 or higher
Cartridge Builder: must be upgraded to 5.6.6 or higher
MySQLAgent: must be upgraded to 5.7.5.90 or higher
PostgreSQLAgent: must be upgraded to 5.7.5.90 or higher
MongoDBAgent: must be upgraded to 5.7.5.140 or higher
CassandraAgent: must be upgraded to 5.7.5.50 or higher
TIBCOAgent: must be upgraded to 5.7.5.16 or higher

The following software has been updated for the Foglight 5.9.5 release:

For a complete list of fixes for any of these components, please refer to the release notes that accompany them. If you decide to maintain the version you have of any of the updated components, as opposed to upgrading, you will not acquire the new fixes for that component.

For more details, see these topics:

Foglight cartridge upgrade issues

NOTE: Any versions earlier than those listed in the Components compatibility list may not be compatible with Foglight 5.9.x. It is recommended that you only use the listed versions.

The following cartridges are not compatible with the Foglight 5.9.x release:

For any Foglight cartridge, follow the instructions in this guide to upgrade the cartridge to the latest version. If any additional information is required to upgrade a particular cartridge, the instructions in this guide will direct you to the release notes for that cartridge for the information.

自助服务工具
知识库
通知和警报
产品支持
下载软件
技术说明文件
用户论坛
视频教程
联系我们
获得许可 帮助
技术支持
查看全部
相关文档