Connection error after upgrading TIC:
Issue 1:
"Error when attempting to connect using Windows Authentication.
There was a connect error. Check that the username and password are correct, that you have registered this user using the registration tab, and that the registered user has not been disabled. Unable to connect to any of the specified Data Service hosts
Unable to connect to any of the specified Data Service hosts."
Issue 2:
After starting/restarting all the TIC services, the following error still occurs when trying to connect to the TIC server from a remote Toad Data Point installation:
"The type initializer for 'System.Net.ComNetOS' threw an exception"
CAUSE 1:
All Toad Intelligence Central services had not started automatically, after upgrade.
CAUSE 2:
Possible cause is that relevant ports are not open to allow for connection. Ports to be opened
Ports 3566, 2166, 8066, 80 (Port 80 is reserved for the web port. During installation, you can change this if required)
RESOLUTION 1:
RESOLUTION 2:
Ensure all required ports are open. Firewall may be blocking the connection. Check if Port 8066 on the machine where the TIC Server resides is open to incoming traffic. Check your firewall settings and allow traffic to this Port.
RESOLUTION 3:
On the machine where TIC server resides, go to Windows Firewall | Advanced Settings | Inbound Rules. Add a 'New Rule' here for Ports 8066, 3566. Both ports can be in one rule. Choose 'TCP' and 'Any' for most of the settings.
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