Chat now with support
Chat with Support

Foglight 5.7.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrade the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploy an agent package using the browser interface

Upgrade Foglight Integration for OpenManage Essentials

The latest version of Foglight Integration for OpenManage Essentials is 5.7.0.

Developed for Foglight Management Server 5.7.5, Foglight Integration for OpenManage Essentials is compatible for use with Foglight for Virtualization Enterprise Edition 8.4 and requires Foglight for VMware 5.7.0.

Upgrade Foglight for OpenStack

The latest version of Foglight for OpenStack is 5.7.3.

Foglight for OpenStack 5.7.3 requires Management Server version 5.7.5.4 (or later), or Foglight for Virtualization, Enterprise Edition 8.4 (or later).

Install Foglight for OpenStack version 5.7.3 (OpenStack-5_7_3.car) as you would install a new cartridge. Do not delete the older version of the .car file. Install version 5.7.3 over the older version.

Upgrade Foglight for PowerVM

The latest version of Foglight for PowerVM is 5.8.5.8.

Foglight for PowerVM 5.8.5.8 requires Management Server version 5.7.5 (or later). Foglight Agent Manager 5.8.5 (or later) must be installed on all the hosts that you want to use for local or remote monitoring.

3
Install Foglight for Infrastructure version 5.8.5.8 (Infrastructure-5_8_5_8.car) on the Management Server as you would install a new cartridge. Do not uninstall or delete the previous version of this file. For complete instructions, see “Installing Foglight cartridges” in the Foglight Administration and Configuration Help.
When installing the Infrastructure-5_8_5_8.car file, the following cartridges are added to the Cartridge Inventory:

Upgrade Foglight Resource Optimizer

The latest version of Foglight Resource Optimizer is 5.7.3.

Foglight Resource Optimizer 5.7.3 requires Management Server version 5.7.5 (or later), or Foglight for Virtualization, Enterprise Edition 8.3 (or later).

Foglight Resource Optimizer for VMware Environments also requires Foglight for VMware version 5.7.3.

Foglight Resource Optimizer for Hyper-V Environments also requires Foglight for Hyper-V version 5.7.3.

NOTE: When upgrading VMware-Optimizer-5_6_16_1.car to version 5.7.0 (or later), follow one of these processes:
Upgrade the VMware-Optimizer-5_7_3.car before upgrading Optimizer-5.7.3 car.
Disable VMware-Optimizer-5_6_16_1.car before upgrading to Optimizer-5_7_3.car and VMware-Optimizer-5_7_3.car.
Foglight for VMware version 5.7.3 (which includes the DRP-5_7_3.car, Virtual-VMware-5_7_3.car and Virtual-VMware-Admin-5_7_3.car cartridge files)
Foglight Resource Optimizer version 5.7.3 (which includes the CommonAnalytics-5_7_3.car, DRP-5_7_3.car, Optimizer-5_7_3.car, and VMware-Optimizer-5_7_3.car cartridge files)
NOTE: After installing the Virtual-VMware-5_7_3.car cartridge, existing vCenter agents (VC agents) must be updated using the Update Agent button in the VMware Environment > Administration tab.
3
If configuration has been previously edited to support larger environments, refer to Foglight for VMware Release Notes to restore the configuration.
Foglight for Hyper-V version 5.7.3 (which includes the DRP-5_7_3.car, Virtual-HyperV-5_7_3.car, and Virtual-HyperV-Admin-5_7_3.car cartridge files)
Foglight Resource Optimizer version 5.7.3 (which includes the CommonAnalytics-5_7_3.car, DRP-5_7_3.car, Optimizer-5_7_3.car, and HyperV-Optimizer-5_7_3.car cartridge files)
NOTE: After installing the Virtual-HyperV-5_7_3.car cartridge, existing HyperV agents must be updated using the Update Agent button in the HyperV Environment > Administration tab.

 

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating