Chat now with support
Chat with Support

Foglight 5.7.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrade the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploy an agent package using the browser interface

Upgrade Foglight for Application Operations

Foglight for Application Operations has been updated to version 5.9.8.4. Upgrades from version 5.9.x, 5.7.x, and 5.6.4.x are supported.

Foglight for Application Operations must be installed on a running Foglight Management Server 5.6.7 or later.

Foglight Agent Managers of version 5.7.0 or later must be installed on all the hosts that you want to use for local or remote monitoring.

Installing this cartridge also upgrades the following cartridges to the following versions:

For a complete list of cartridges included in Foglight for Application Operations, see the Foglight for Application Operations Release Notes.

Install Foglight for Application Operations 5.9.8.4 (Application-Operations-5_9_8_4.car) as you would install a new cartridge. Do not delete the previous version of the Cartridge for Dependency Mapping or Foglight for Application Operations.

For detailed cartridge installation instructions, see “Installing Foglight Cartridges” in the Foglight Administration and Configuration Help.

Upgrade Foglight APM for Real User Experience

The latest version of Foglight APM for Real User Experience is 5.9.10. This release of Foglight APM for Real User Experience is compatible with:

For appliance-hosted Management Servers and all appliances, the upgrade is done via an APM dashboard. For details, see section “Updating appliance software” in the Foglight APM Administration and Configuration Guide, or Upgrade appliance software.

For server-hosted Management Servers, after you update the appliance software, you need to install the Foglight APM cartridge (EndUser-5_9_10.car) on each server-hosted Management Server. You also need to confirm some dependencies. For details, see section “Installing Foglight APM cartridges” in the Foglight APM Installation and Setup Guide, or Upgrade Foglight APM cartridges.

Upgrade appliance software

You can download Foglight APM software updates from Support Portal. When you upload the update package into Foglight, all Foglight APM Appliances are updated at the same time.

Direct upgrades are only supported from Foglight APM version 5.9.9. Upgrading from versions prior to 5.9.9 requires more than one step. Before you begin, obtain all the necessary Foglight APM for Real User Experience upgrade packages from the Support Portal.

2
On the navigation panel, under Dashboards, click APM > Support > Update Appliance Software.
3
Click Update Appliance.
The Update Appliance Software dashboard opens in a separate web browser window.
To upgrade from version 5.9.9—Follow the instructions in Step 5 to Step 9, using the Foglight APM for Real User Experience 5.9.10 upgrade package file.
To upgrade from version 5.9.8—Follow the instructions in Step 5 to Step 9, using the Foglight APM for Real User Experience 5.9.9 upgrade package file. When this upgrade is complete, repeat the instructions in Step 5 to Step 9, using the Foglight APM for Real User Experience 5.9.10 upgrade package file.
To upgrade from version 5.9.7—Follow the instructions in Step 5 to Step 9, using the Foglight APM for Real User Experience 5.9.8 upgrade package file. When this upgrade is complete, repeat the instructions in Step 5 to Step 9, using the Foglight APM for Real User Experience 5.9.9 upgrade package file. When this upgrade is complete, repeat the instructions in Step 5 to Step 9, using the Foglight APM for Real User Experience 5.9.10 upgrade package file.
5
On the Update Appliance Software dashboard, click Begin New Update.
6
In the Choose Appliance Upgrade Package File to Upload (.pkg) dialog box, browse to and select the software update package that you saved to your local disk, and click Start Upload.
7
Click Start Upgrade.
8
Click Finish to return to the Update Appliance Software dashboard.
9
To review the full log, click the View Details link on right side of the dashboard. If you need help resolving any upgrade issues, contact Quest Support.

Upgrade Foglight APM cartridges

Foglight APM cartridge is called EndUser-x_x_x.car (where x_x_x refers to the current version number). The Foglight APM cartridge depends on functionality included in the Foglight for Application Operations cartridge. If a supported version of Foglight for Application Operations is not currently installed, you need to install it before you install the Foglight APM cartridge. Refer to the Foglight APM Release Notes for the supported cartridge version numbers.

Install the cartridges in the same way you installed your other Foglight cartridges. There is no agent component to install; the Sniffer takes the place of an agent. If you need help, open the action panel and click the Help tab.

2
In the bottom right of the browser window, click About. Ensure that you are running at least Foglight 5.7.5.3 (or later).
3
Navigate to Administration > Cartridges > Cartridge Inventory.
Application-Operations-5_9_8_2.car (or later)—This cartridge must be installed first for new installations. Updated in this release.
EndUser-5_9_10.car—Required. Updated in this release.
ApplicationServers-DotNET-5_9_8.car (or later)—Required for monitoring .NET® applications. Updated in this release.
ApplicationServers-Java-5_9_8.car (or later)—Required for monitoring Java® applications. Updated in this release.
5
Verify successful installation. Navigate to Administration > Cartridges > Cartridge Inventory.
ApplicationServers-DotNET 5.9.8 (or later, if you are monitoring .NET® applications)
ApplicationServers-Java 5.9.8 (or later, if you are monitoring Java® applications)
Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating