Chat now with support
Chat with Support

Foglight 5.7.5 - Upgrade Guide

Understand product versions Best practices Upgrade the Foglight Management Server Upgrade the Foglight Agent Manager Upgrade the Application Monitoring cartridges Upgrade the Database cartridges Upgrade the End User Management cartridges Upgrade the Infrastructure Management cartridges Upgrade the Integration cartridges Upgrade the cartridges in a federated or High Availability (HA) environment Appendix: Deploy an agent package using the browser interface

Upgrade order

To upgrade your Federation servers to 5.7.5.8, follow the appropriate procedure below.

2
Clear the list of JndiURLs in the Federation Master’s federation.config.

Any Federated Child that is not being upgraded to the same cartridge version configuration as the Federation Master should be left out of the federation. All Federated Child instances of that type can be federated using a second Federation Master that has the older configuration, if necessary.

A Federated Child that you upgrade later can be added by following the instructions in Step 6.

Upgrade the Management Server in a High Availability (HA) environment

The procedure for upgrading the servers in an HA environment is the same as described in Upgrade the Management Server. There are a few items in particular that should be noted when working in an HA environment. These are:

2
If you have modified the Cluster-Service.xml files, back them up before performing the upgrade and then restore them after the upgrade.

Upgrade the Management Server with an Oracle RAC database

This section provides instructions for upgrading Oracle® RAC-based installations and any other environments where the Management Server *-ds.xml files were customized.

2
Save the *-ds.xml and server.config files.
3
Manually enter or copy the JDBC URL from the saved *-ds.xml into the server.database.url property of the current server.config file.

Oracle database users

A Management Server 5.7.5.8 using an Oracle® database makes use of stored procedures in the Oracle database. When upgrading from a version earlier than 5.6.2 to version 5.6.2 or later, the procedures are created during the upgrade process. To allow the upgrade process to create the stored procedures, a DBA user must first assign the CREATE PROCEDURE privilege to the database user used by Foglight.

where <foglight> is the name of the database user used by the Foglight application

If the upgrade process is run without assigning the CREATE PROCEDURE privilege to the Oracle database user, the database upgrade will fail with the following error:

The Oracle database user has not been assigned the CREATE PROCEDURE privilege.

Once the CREATE PROCEDURE privilege is assigned to the database user, the database upgrade process can be run manually by invoking the foglight_db_upgrade script.

Related Documents

The document was helpful.

Select Rating

I easily found the information I needed.

Select Rating