Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
Enterprise Reporter 3.5 Hotfix #2 Full Maintenance Release
Description
Enterprise Reporter 3.5 Hotfix #2 is a maintenance release that addresses the issues noted below as well in the attached Release Notes. This release can also be used by customers who are installing Enterprise Reporter for the first time.
Resolved Issues:
Unable to supply credentials in UPN format for non Azure accounts. Support added and now able to specify credentials in UPN format and select if account is an Azure credential - 438083
Active Directory discovery failing and generating a null reference error - 438355
Reports are only displaying the first service principal name when multiple service principal names are set in Active Directory - 438807
Active Directory discovery fails to generate multiple tasks for domain and discovery processing does not proceed - 438811
Database Utility dialog does not provide adequate information on the requirement of an empty database for the restore and transfer tasks - 439790
Resolved issues in Hotfix #1 which are included in Hotfix #2:
SMTP OAuth - 386327, 401968
Azure AD Graph API and MSOnline updates - 389894, 393347
Exchange Online property changes - 400967
Deprecation of Remote PowerShell in Exchange Online - 404977
Fixes for licensing issues - 407740
Fixes for NTFS discovery on Netapp devices - 416025
ER Powershell cmdlet fixes for multi-cluster environments - 417239
Cause
This Full Maintenance Release addresses the issues described in the attached Release Notes article. Please review the problem descriptions included to ensure your issue criteria is met prior to installing this Full Maintenance Release.
Resolution
Download the maintenance hotfix #2 by Clicking Here To install the hotfix:
Open the Configuration Manager and ensure there are no discoveries running
Disable and stop all running nodes
Close Configuration Manager
Run the installer for hotfix
To upgrade all components, click Next. To upgrade individual components, click the drive icon on each component, select desired option and click Next
If you are upgrading the server, you need to upgrade the database. The Database Wizard will be automatically displayed to upgrade existing database. Proceed through database upgrade by selecting existing options and clicking Next
Once the server and database upgrade is complete, open the Configuration Manager and any nodes that need to be upgraded will be displayed with Incompatible Version
Upgrade all nodes from the Configuration Manager. For nodes that were deployed manually, you will need to manually upgrade them
For machines that you only have the Configuration Manager and Report Manager installed, run the installer to have them upgraded
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Enterprise Reporter
3.5
Topic(s):
Best Practices, Configuration, Installation, Troubleshooting
Article History:
Created on: 6/20/2023 Last Update on: 9/13/2023
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Welcome to Quest Support
You can find online support help for Quest *product* on an affiliate support site. Click continue to be directed to the correct support content and assistance for *product*.
The Quest Software Portal no longer supports IE8, 9, & 10 and it is recommended to upgrade your browser to the latest version of Internet Explorer or Chrome.