Getting email alerts as expected, but one is coming frequently. It is just a blank email with no subject line. Sometimes it has been send up to five of them within several minutes, and then no one for a few hours. All the activated rules have not been configured with a blank Alarm message.
CAUSE 1
Rules without subject defined for email action
CAUSE 2
Recent releases of the Foglight for Database cartridges (e.g. SQL Server and Oracle) email configuration has been moved to the Global Administration. Configuration for alarm emails should be undertaken in this location. Database related rules on the "Rules Management" dashboard should have email addresses removed to stop blank emails from being generated.
RESOLUTION 1
There is a groovy script that can be run to find out rules have blank messages or subjects (see attached script). Once the script has been run, those rules can be edited for the correct message or subject.
Here is how to run the script:
- Place the groovy script in the $FMS_HOME/bin directory
- At $FMS_HOME/bin command prompt type:
UNIX:
./fglcmd -usr foglight -pwd foglight -port 8080 -srv localhost -cmd script:run -f CheckForEmptyEmailActions.groovy
Windows:
fglcmd -usr foglight -pwd foglight -port 8080 -srv localhost -cmd script:run -f CheckForEmptyEmailActions.groovy
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