When a database agent is activated the monitored the collections running cause high CPU on the monitored database instance.
When the Foglight database agent is turned off the CPU activity on the host returns to normal.
Some Queries may appear to create a performance impact on a monitored Database Instance when SQL PI is enabled.
Instances with little to no activity (e.g. newly built instances with no production databases), or during periods of low activity on a production database may exhibit high Foglight monitoring activity.
High Foglight monitoring activity from SQL PI monitoring may appear to to using Instance resources as the collections run every 1 second/1000ms. This is normal and a default behavior.
This may not be noticed on a normally operating Database Instance with some levels of workload.
Deadlock collection using Extended Events in SQL Server
Cause 2
Foglight environment sizing or antivirus requirements are not met.
SQL PI "get_active_waits" query for SQL Server monitoring
If a firewall kills/interrupts a database session, the database session itself does not realize that the session has gone. The database keeps the session open. Foglight will create a new session.
Connectivity issue to an Oracle host
Database maintenance not up to date.
Disk performance
Resource contention
SQL Server Error Log collection OS DCOM retrieval of the SQL Server Error Log.
** This is the most common solution issue SQL Server agents **
Refer to KB 4228897 with an immediate suggestion to change the Deadlocks collection in SQL Server from Extended Events to Trace.
Resolution 2
Please see the current Foglight for Databases deployment guide check the SQL PI environment sizing and requirements.
Please see KB 4226229 to reduce the collection workload from SQL PI (for SQL Server hosts)
Please refer to KB 4295218 for more details on this issue
Please refer to KB 4295218 for more details on this issue (for Oracle hosts)
Optimize table indexes, Update Statistics, run regular maintenance tasks etc to improve Instance performance.
Disk performance and physical file locations should be reviewed and confirmed to not be contributing to instance performance.
Investigate Instance Memory tuning. Ensure the instance memory is not using all resources and there is enough left for base OS and other third party app operations. Other Third Party monitoring tools run in conjunction with Foglight and may be competing for available resources.
Change the SQL Server Error Log collection for the database agent from OS or FALLBACK to JDBC as described in KB 4302796
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