Unable to unlock the DB2 agent using the "Unlock Agents" panel in the Database Technical Support Dashboard. The message "Failed to unlock agent - check logs for more details" appears in a popup.
The following message appears in the FMS log.
YYYY-MM-DD HH:MM:SS.SSS VERBOSE [http-0.0.0.0-8080-91] STDOUT - Failed to unlock OS for agent with ID = 1172 - The exception was: RemoteException occurred in server thread; nested exception is:
java.rmi.RemoteException: Cannot invoke unlockOS method. Reason : agent id [DB2-HOSTNAME-INSTANCE] is not registered in the server
CAUSE 1 *This is the most common cause*
The Foglight Agent Manager has insufficient Java Heap resources configured
CAUSE 2
The result is that the UI item (that invoked the RMI function) doesn't contain data at all
CAUSE 3
An agents monitors a DB, works and then stops for a while
CAUSE 4
Another agent monitors the same DB, starts and invokes an RMI function such as Unlock
RESOLUTION 1
Increase the Java Heap Memory configuration on the monitored host as described in KB article 87568
Delete the database agent monitoring the DB2 instance and recreate the agent using the DB2 database installer.
RESOLUTION 4
Restart the FMS
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