El envío de formularios en el sitio de soporte no está disponible temporalmente para programar el mantenimiento. Si necesita asistencia inmediata, comuníquese con el soporte técnico. Disculpe las molestias ocasionadas.
Verify Connection Error--ORA-28040: No matching authentication protocol Driver
Descripción
Verify Connection Error--ORA-28040: No matching authentication protocol Driver: oracle.jdbc.driver.OracleDriver URL:
Causa
Database upgraded to Oracle version 12g (12.1.0.1.0)
Resolución
WORKAROUND:
Stat 5.6.4 has not been tested or certified with Oracle 12c. Below are the workaround:
1. Logon to stat central agent machine and stop the agent. Go to app\bin and locate the run.bat or run.sh file (depending on the OS, unix or windows). Take a good back-up of the run.bat file. Make sure to place it in a different directory than the stat central agent even if the file contains different name. 2. Look for this line
if "x%JBOSS_CLASSPATH%" == "x" ( set "RUN_CLASSPATH=%RUNJAR%" ) else ( set "RUN_CLASSPATH=%JBOSS_CLASSPATH%;%RUNJAR%" )
3. Add a line directly above it to set the JBOSS_CLASSPATH to the location of where your Oracle ojdbc6.jar file is. Include the full file path with the file name. If the file path has spaces, then you will need quotes set in a similar fashion to this statement: set "JAVA_HOME=C:\Program Files (x86)\Java\jdk1.6.0_45" The start quote goes right before JBOSS and the end quote is after the file name.
set JBOSS_CLASSPATH=ojdbc6.jar if "x%JBOSS_CLASSPATH%" == "x" ( set "RUN_CLASSPATH=%RUNJAR%" ) else ( set "RUN_CLASSPATH=%JBOSS_CLASSPATH%;%RUNJAR%" )
4. Save the file and restart the Stat agent.
One other customer with same issue implemented the following workaround:
Added the last line (SQLNET.ALLOWED_LOGON_VERSION=8) to the sqlnet. ora file on the database server -
This allows the connections to HRDEV92 (Oracle 12) and HRTST92 (Oracle 11) to be successful. HRTST92 was also successful with version 9, but HRDEV92 (Oracle 12) worked only after changing the version to 8.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Bienvenido al portal de soporte
Puede encontrar ayuda de soporte en línea para el *producto* Quest en un sitio de soporte afiliado. Haga clic en Continuar para ser dirigido al contenido de soporte y a la asistencia adecuados para el *producto*.
Buscar todos los artículos
IE 8, 9 y 10 ya no son compatibles
El portal de Quest Software ya no admite IE 8, 9 ni 10 y se recomienda actualizar el navegador a la última versión de Internet Explorer o Chrome.