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Workload Analysis has a long loading delay and results in Error retrieving data: ClientConnectIssue: A task was canceled."
Descripción
When clicking on Workload Analysis, there is long loading delay and something follow by the error "Error retrieving data: ClientConnectIssue: A task was canceled."
Causa
The Diagnostic Server maybe out of memory. Adjust the SpotlightDiagnosticServer.ini file to increase the memory limit of the Diagnostic Server.
Resolución
WORKAROUND:
1. Backup the file {Diagnostic Server dir}\Agent\bin\SpotlightDiagnosticServer.ini into a different directory
2. Edit the file
3. Change "-Xmx4096m" to "-Xmx8192m"
4. Save the file
5. Restart the Diagnostic Server service
STATUS:
A fix is available in the latest version of Spotlight on SQL Server Enterprise which can be downloaded here.
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