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Getting Access is denied for Computer Discovery even though discovery account has local admin rights
Description
When running a discovery get error message "Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED))" the account used for the discovery is a domain admin and it is in the local admin group.
Cause
Connecting to WMI and the Remote Registry on the targets is required.
Resolution
To test WMI:
Log into the server that hosts the ER node using the service account that is used to run the SQL discovery
Go to Start then Run and type in 'wbemtest' and hit enter
Click on the Connect button and then for the namespace type in: \\targetservername\root\cimv2
Click Connect
If connections fails, check Microsoft documentation regarding WMI Troubleshotting
The documentation provided on this link is as is and it has not been tested from our support engineers
To test Remote Registry:
On the node, logged in as the node credentials, open regedit
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Enterprise Reporter
3.5, 3.2.2, 3.2.1
Topic(s):
Troubleshooting
Article History:
Created on: 4/16/2015 Last Update on: 3/20/2024
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Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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