Unable to install product suite. When trying to install Toad, getting the error below. The issue happens on the .EXE file, but can also happen on the .MSI file.
ERROR:
"The installer was not able to complete successfully.
RegisterComplete returned error code [0x80070005].
ApplyComplete returned error code [0x80070005].
OR
RegisterComplete returned error code [0xXXXXXXXX].
OR
OR
System.DllNotFoundException
OR
This installation package could not be opened. (MSI installer)
Cause 1:
McAfee anti-virus is denying the installer access to update registry.
Cause 2:
Previous installation attempt is left running in the background.
Cause 3:
Corrupt Toad installer file and/or the downloaded file seems incomplete as the file size seems to be always different.
Cause 4:
User does not have enough privileges to install Toad for Oracle using an .EXE file
Cause 5:
Change Environment Variables to the windows temp directory.
Cause 6:
Using a WEB installer without having access to the internet.
Cause 7:
RESOLUTION 1:
Where possible, disable McAfee anti-virus for the duration of the installation. If you cannot disable your anti-virus, use Resolution 4 below.
RESOLUTION 2:
Ensure any previous attempts to run the installation is fully exited or ended. Ensure it is not running in the background. Try rebooting your PC and run the installation again.
RESOLUTION 3:
Delete the current installer file and download it again.
Ensure you download the Toad installation file 'directly' to your Windows 'Desktop' location or root C:\ drive (not any network drives). Run it from your 'Desktop' location as well (right-click it and choose 'Run as Administrator').
If you initially downloaded to a network drive, delete that file and download Toad again; do not 'move' the previously downloaded install file from your network drive to your Desktop location.
If each time you download Toad, the downloaded file size seems to be always different, a firewall may be blocking parts of the download. Please try downloading Toad again, but from a different network location or domain.
RESOLUTION 4:
If user does not have Administrator Rights to install Toad for Oracle using an .EXE file, download and use the Toad for Oracle .MSI Installer (Special Installation Only) zip file instead.
See How to run a silent installer as administrator
If the .MSI file also does not work, please have your IT / Help Desk / Network Admin people install the product for you.
RESOLUTION 5:
Further details on these similar errors at these KB sites:
Installer, Unable to install, getting the [8007051B] or [0x80070002] or [0x80070005] error.
RESOLUTION 6:
If you downloaded the 'Web' installer, please use the 'Full' installer or the 'MSI' installer instead. Ensure you download it 'directly' to your local hard drive or Windows 'Desktop' location, not any network drives.
RESOLUTION 7:
Ensure you have write access to the “%TEMP% folder. Clean out all files in %TEMP% folder and try the installation again.
Ensure you have write rights access to the “%ProgramData%\Package Cache” folder. Clean out all files in “%ProgramData%\Package Cache\” folder and try the installation again.
RESOLUTION 8:
The "System.DllNotFoundException", "Unable to load DLL 'ToadPro.dll'" installation error can be solved by a reinstallation of Windows.
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