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Stat Central Agent Status shows Not Responding but a Java process is alive on the server.
Description
Debugging User issues. Bounced the Central agent and apparently did something in err with JAVA. default.war.failed stat-config.war.failed stat-agent.ear.failed
Debugging the issue and discovered that, although the STAT client indicated that the Central Agent was down, there was an active STAT process running on the host server.
Therefore there was conflict with the ports. I terminated that backup process, and the startup now has different messages.
Cause
It can happen if the Java process (SCA) is not shut down properly and let an orphan process running.
In this situation, you will see the SCA in 'Not Responding' status, and a java process alive on the server.
In this scenario, any new SCA starting up will fail with many different errors.
Resolution
Solution:
1. Shut down the SCA alive processes or kill them. If Windows you can use TaskManager.
2. Delete the *.failed files generated.
3. Delete the cache directories (data, log, and tmp)
4. Start the SCA
NOTE: you can have multiple SCA running BUT these must point to different DB and use a different port.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Stat
6.2
Topic(s):
Troubleshooting
Article History:
Created on: 6/8/2021 Last Update on: 5/7/2023
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Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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