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Workload Analysis has a long loading delay and results in Error retrieving data: ClientConnectIssue: A task was canceled."
Description
When clicking on Workload Analysis, there is long loading delay and something follow by the error "Error retrieving data: ClientConnectIssue: A task was canceled."
Cause
The Diagnostic Server maybe out of memory. Adjust the SpotlightDiagnosticServer.ini file to increase the memory limit of the Diagnostic Server.
Resolution
WORKAROUND:
1. Backup the file {Diagnostic Server dir}\Agent\bin\SpotlightDiagnosticServer.ini into a different directory
2. Edit the file
3. Change "-Xmx4096m" to "-Xmx8192m"
4. Save the file
5. Restart the Diagnostic Server service
STATUS:
A fix is available in the latest version of Spotlight on SQL Server Enterprise which can be downloaded here.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Spotlight on SQL Server Enterprise
12.2, 12.1, 12.0.1, 12.0, 11.7.1, 11.7, 11.6.2, 11.6.1, 11.6
Topic(s):
Troubleshooting
Article History:
Created on: 11/10/2016 Last Update on: 5/7/2023
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Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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