Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
Increase the number of AppRecovery.log Files to keep data in the logs longer
Description
In environments with a very busy core, log files recycle too quickly, making it challenging to capture the necessary data for troubleshooting. This rapid log recycling impedes the ability to provide complete support logs, thus complicating the resolution process.
Cause
A high-activity core generates large amounts of log data, leading to the frequent recycling of log files. Consequently, the duration for which information is retained in the logs is significantly reduced.
Resolution
Note: If you run a repair installation or upgrade the application, this setting will likely revert, and you will need to perform the modification again.
Increasing the number of log files may not be sufficient. If necessary, you can also increase the size of the log files. For detailed instructions on how to do this, please refer to the following Knowledge Base article: Increase the size of the Rapid Recovery AppRecovery.log files.
To increase the number of log files retained before Rapid Recovery starts recycling them, follow these steps:
Stop the Core service.
Navigate to C:\Program Files\AppRecovery\Core\CoreService.
Locate the Logging.dll.nlog.config file and make a backup copy of it as a safeguard.
Open the original Logging.dll.nlog.config file in Notepad.
Find the following line: <target name="logfile" xsi:type="File"> maxArchiveFiles="3" </target>
Change the value of maxArchiveFiles to a larger number, depending on how quickly your logs are recycled. For example, you might change it to maxArchiveFiles="10".
By increasing the number of log files retained, you extend the duration that log data is available, thereby enhancing the support team's ability to diagnose and resolve issues effectively.
Additional Information
Logs, Apprecovery.log, extended logging, more logs, extend logs, add.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Rapid Recovery
6.9, 6.8, 6.7, 6.6, 6.5
Topic(s):
How To
Article History:
Created on: 4/12/2016 Last Update on: 6/24/2024
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Welcome to Quest Support
You can find online support help for Quest *product* on an affiliate support site. Click continue to be directed to the correct support content and assistance for *product*.
The Quest Software Portal no longer supports IE8, 9, & 10 and it is recommended to upgrade your browser to the latest version of Internet Explorer or Chrome.