Date: JUN 2010
Product & Version: SmartDisk 1.1
OS Version: all
Symptoms:
When a customer shutdown the operating system on the smart disk server the Smartdisk processes get terminated before smartdisk can shutdown. This can cause index corruption on the smartdisk so to avoid this; a manual shutdown of smartdisk was tried. This seems to fail but in reality does not as this can takes up to 45 minutes.
Cause:
Stopping the Deduplication processes take longer than system shutdown time and processes get terminated.
The fastest way to stop the smartdisk services is to disabled Deduplication and all dedupe processes will stop. Once the Deduplication process have stopped stop smartdisk from the command line as seen below
SmartDisk\foundation\bin>smartdisk.bat config --dedupe-enable false
SmartDisk\foundation\bin>smartdisk.bat stop
Having stopped smartdisk in this manner, use the following commands to start smartdisk and re-enable deduplication...
SmartDisk\foundation\bin>smartdisk.bat start
SmartDisk\foundation\bin>smartdisk.bat config --dedupe-enable true
Prepared by:
Richard Downes
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