Issue
Migrations were operating concurrently across 16 workers. Soon, workers start failing to initialize.
We opened Outlook and realized it can't open/access the INBOX for any user's account with the migration account.
The migration account has 'Full Access' to the Exchange mailboxes.
Received this error when trying to open Outlook:
"Cannot open your default email folders. Microsoft Exchange is not available"
Cause
For on-premise Exchange migrations, a throttling policy must be created to set the session and message count to 'unlimited', and then applied to the migration user account.
By default, Exchange has a throttling policy applied at the global level.
Note: To our knowledge there is no way to apply this in Office 365, which means the use of multiple migration accounts, generally assigned to a group. This group is then granted 'Full Access' to the mailboxes for migration.
Solution
Use this PowerShell command to remove the Throttling Policy in Exchange for your migration user account. "ExMigrate" In this case.....
The first line creates a brand new throttling policy called "SuThrottlingPolicy", which sets throttling to 'Unlimited'.
The second line then assigns this policy to the migration account, "ExMigrate".
set-ThrottlingPolicy SuThrottlingPolicy -EwsMaxConcurrency Unlimited -RcaMaxConcurrency Unlimited
Set-ThrottlingPolicyAssociation -Identity exmigrate -ThrottlingPolicy SuThrottlingPolicy
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