Trying to mailbox-enable a user after a merge and you see the following in the log file.
22:02:51 Scanning user list for problems.
[BEGINUSER=User@test.com]
22:02:51 ERROR: [1325-52-19-00000000] Search for '(|(mail=User@test.com)(proxyAddresses=SMTP:User@test.com)(targetAddress=SMTP:User@test.com))' found 2 objects.
[ENDUSER=User@test.com]
Cause 1:
There is more than one object found with the address in 2 or more of theses attributes:
mail=User@test.com
proxyAddresses=SMTP:User@test.com
targetAddress=SMTP:User@test.com
This could be a replication issue if the user was just merged, Or if there is more than one object.
Cause 2:
MNE has been configured to Mailbox-enable directly from contact objects
Resolution 1:
If you have just merged the object wait a few minutes and try again. If that doesn't work, This test may help you in identifying what objects exist:
While in AD users and computers:
1) Right Click on the domain that the user account resides in
2) Choose 'Find'
3) In the 'Find' drop down list (top left of window), drop the list down and select 'Custom Search'
4) Select the 'Advanced' tab
5) Paste this value into the 'Enter LDAP query' window (use the line located in your log file)
(|(mail=User@test.com)(proxyAddresses=SMTP:User@test.com)(targetAddress=SMTP:User@test.com))
This will identify what objects have these values.
Resolution 2:
Revert MNE back to the normal configuration in the MNE Global Default Settings. The below example shows the default settings:
[ActiveDirectory]
ContactFilter=(objectClass=contact)
UserFilter=(objectClass=user)
MboxfromContact=0
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