Chat now with support
지원 담당자와 채팅

NetVault Backup Plug-in for PostgreSQL 12.3 - User Guide

Introducing NetVault Backup Plug-in for PostgreSQL Installing and removing the plug-in Configuring the plug-in Backing up data Restoring data Troubleshooting

Target audience

While advanced DBA skills are not required to create and run routine backup operations, they are required for defining an efficient backup-and-recovery strategy.

Recommended additional reading

Quest recommends that you have the following documentation available for reference while setting up and using this plug-in.

Quest NetVault Backup Installation Guide: This guide provides details on installing the NetVault Backup Server and Client software.
Quest NetVault Backup Administrator’s Guide: This guide explains how to use NetVault Backup and describes the functionality common to all plug-ins.
Quest NetVault Backup CLI Reference Guide: This guide provides a description of the command-line utilities.

Installing and removing the plug-in

Installation prerequisites

Before installing Plug‑in for PostgreSQL, verify that the following software is installed and properly configured on the machine designated as the PostgreSQL Server:

NetVault Backup Server or Client software: At least the Client version of NetVault Backup must be installed on the machine configured as the PostgreSQL Server. For more information on supported versions of the NetVault Backup software, see the Quest NetVault Backup Compatibility Guide.
PostgreSQL software: The machine must be running a supported version PostgreSQL. For more information, see the Quest NetVault Backup Compatibility Guide.
The Custom Archive backup format requires the zlib compression library. This library is included by default during PostgreSQL installation unless you specify the --without-zlib option. Do not use the --without-zlib option if you intend to use Custom Archive backup format.
관련 문서