Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
Workload Analysis has a long loading delay and results in Error retrieving data: ClientConnectIssue: A task was canceled."
설명
When clicking on Workload Analysis, there is long loading delay and something follow by the error "Error retrieving data: ClientConnectIssue: A task was canceled."
원인
The Diagnostic Server maybe out of memory. Adjust the SpotlightDiagnosticServer.ini file to increase the memory limit of the Diagnostic Server.
해결 방안
WORKAROUND:
1. Backup the file {Diagnostic Server dir}\Agent\bin\SpotlightDiagnosticServer.ini into a different directory
2. Edit the file
3. Change "-Xmx4096m" to "-Xmx8192m"
4. Save the file
5. Restart the Diagnostic Server service
STATUS:
A fix is available in the latest version of Spotlight on SQL Server Enterprise which can be downloaded here.