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Error "MailboxNotEnabledForRESTAPI" when trying to set up email alerts using the Microsoft 365 Mail option
설명
Receiving the following error when trying to configure email alerts using Microsoft 365 Mail:
Code: MailboxNotEnabledForRESTAPI Message: The mailbox is either inactive, soft-deleted, or is hosted on-premise. ClientRequestId: AppID
원인
An issue with the mailbox in Microsoft O365
해결 방안
Try to manually create the Change Auditor API instead of doing it automatically from the Change Auditor Windows client:
https://support.quest.com/kb/4369790
Verify that the specified mailbox exists in your O365 and that was correctly set up, licensed, and active. This means that is not soft-deleted (A soft-deleted mailbox has been deleted but can still be recovered in Microsoft 365 Admin center), or it is not an On-Premise mailbox (hosted on an on-premise Exchange server and not in the cloud. The REST API only works with mailboxes hosted in Microsoft 365.)
Try with another mailbox to discard that the issue could be the specified mailbox itself.
Make sure the sender mailbox address you are using has REST API access and Exchange Online services enabled: