Incorrect Sender is shown in Outlook after Migration with Migrator for Notes to Exchange (MNE).
Cause 1:
This issue was experienced in the following scenario:
John Smith (John.Smith@Wingra.com) was migrated to Exchange and his person record was set in Notes, as a contact (Other Internet Mail).
Another Notes user Sarah Jones (Sarah.Jones@Wingra.com), has her mail forwarding set in Notes to forward to John.Smith@Wingra.com and MNE Directory Export associates the address "John.Smith@Wingra.com" as an alias of Sarah Jones rather than the Target Address of John Smith.
MNE Directory export had associated the SMTP address with the first object it reads the address from.
This can result in an incorrect Meeting Owner or Mail Sender Address on migrated appointments in the migration of users who had received mail or meetings from John Smith.
Cause 2:
This issue occured in a migration to Office 365. The "Sender" in the orginal Notes email was "user@domain.com". However, there was already an object in Office 365 with "user@domain.com" as a proxyAddress, but this object's primary SMTP address was "user@example.com". When the email was migrated to Office 365, the "Sender" was resolved to "user@example.com" in Office 365, which is not the same as the original Notes sender.
Resolution 1:
It's possible to resolve this issue by opening the Directory Export window in MNE and the export all objects to a TSV file.
Remove the alias for the sender from the "Target Aliases" column of the incorrectly associated user object and define the SMTP address as the "Target Address" of the correct user. In the scenario above we removed John.Smith@Wingra.com as a "Target Alias" of Sarah Jones and defined this as the "Target Address" of the John Smith object.
Import the modified TSV and data migration should then be migrated with the correct sender.
Resolution 2:
Turn off "Resolve attendees" on the Exchange Server screen in the MNE Migration Manager.
One of the symptoms of this issue will be missing addresses in the "SMTP Addresses" in the directory export window. Check the Notes person record for these contacts and if an Internet Address is defined then it's likely that the SMTP Address has been associated with the wrong user as a target alias.
This issue was found with NME version 4.5.4.123.
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