There 4 active alarms for 4 agents. However, the agents are collecting data.
CAUSE 1
The Idle Agents rule activated to fire if an agent is in idle for more than 24 hrs.
CAUSE 2
Issue was caused by numerous DB agents firing alarms hourly due.
RESOLUTION 1
1) Duplicated entries for the agents for which the alarm was triggering.
In Administration | Tooling | Script Editor
Select Agents topology types and selected List Instances.
Found the null agent types and determined there were some SQL Server (DBSS) duplicates.
Locate the actual DBSS duplicate which was stale by selecting that agent in the listing and review the Last Update fields:
lastUpdated 2011-12-02 12:26:36.059
name AAA-DBSS-HOSTNAME
lastUpdated 2010-05-02 08:02:06.036 name AAA-DBSS-HOSTNAME
2) So for the agents which are 'stale', select each one individually in the Tooling | Script Editor | Topology Type = Agent | List Instances.
Select the targeted agent (agents with the very old lastUpdated field), then run:
server.TopologyService.deleteObject(scope)
3) Repeat for other agents and performed the same for the 'null' agents
RESOLUTION 2
Follow steps in KB 156825
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