When attempting to register and add a restored backup EDB file in Recovery Manager for Exchange the wizard starts but fails with the following error message:
"Unable to connect to <<Path to location of EDB>>' database (attach: ''): Non database file or corrupted db"
CAUSE 1
The Exchange EDB was taken from an Exchange Server running on a 64Bit platform.
The Recovery Manager for Exchange (RMEX) server maybe running on a 32Bit platform and is not able to read the backup created on 64Bit platform.
CAUSE 2
If Recovery Manager is working with a Exchange 2010 EDB created on a Windows 2008 SP2 server, then Recovery Manager needs to be installed on a server running the same OS and service pack version.
CAUSE 3
There is some form of corruption in the EDB file. Even if the file can be mounted in a Recovery Storage Group (RSG), and running ESEUTIL /G and ESEUTIL /MH shows that database as clean and consistent, there may still be corruption that Recovery Manager for Exchange cannot get past.
RESOLUTION 1 (for Cause 1)
Install RMEX on a 64Bit server then test Adding Storage and Restoring from the restored EDB.
RESOLUTION 2 (for Cause 2)
Install RMEX on the same Operating System (including Service Pack number) as the OS where edb file was last written to before backup.
Example:
Exchange 2010 installed on Windows Server 2008 SP2 - RMEX Installed on Windows Server 2008 SP2
Exchange 2010 installed on Windows Server 2008 R2 - RMEX installed on Windows Server 2008 SP2 - RMEX will give error "Non database file or corrupted db"
RESOLUTION 3 (for Cause 3)
If neiter Resolution 1 or 2 work, or apply to your environment, try adding the EDB file by using the 'Perform a hard repair on the database' option on the Specify Exchange Database Files page of the Add Storage Wizard. Please ensure you have a copy of the EDB file before trying to add it with the hard repair option selected.
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