Frequent VMW Agent Messages alarms for "The agent has entered an invalid state..." are triggered for a VMWare agent.
In the VMWare agent logs the following type of messages are present.
INFO [Quartz[0]-2568] com.quest.agent.esx.task.ESXAgentTask - Logging Agent Messages [Fatal-The agent has entered an invalid state and is unable to proceed with normal operation. This situation may be self-correcting. However, if you continue to see this message, please deactivate the agent and then reactivate it one or two minutes after deactivation completed. If the situation continues please contact Quest Support
ERROR [Quartz[0]-2570] com.quest.agent.esx.task.ESXAgentTask - Inventory and Relations - Error during execution: ERROR: java.rmi.RemoteException: VI SDK invoke Login, exception:DocumentException:null; nested exception is:
org.dom4j.DocumentException
java.lang.IllegalStateException: java.rmi.RemoteException: VI SDK invoke Login, exception:DocumentException:null; nested exception is:
org.dom4j.DocumentException
...
Caused by: java.rmi.RemoteException: VI SDK invoke Login, exception:DocumentException:null; nested exception is:
org.dom4j.DocumentException
...
Caused by: org.dom4j.DocumentException
...
Caused by: java.net.MalformedURLException
CAUSE 1
Possible network connectivity issue with vCenter.
CAUSE 2
Possible issues with domain authentication in the environment.
RESOLUTION 1
Please verify that there are no network connectivity issue from Agent Manager (FglAM) host to target vCenter on port 443 and agent account has required roles assigned.
RESOLUTION 2
To rule out issues related to the domain account in use, configure the agent to use a local vCenter account.
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