Mail/Public Folder agents are unable to log on to mailboxes, and you receive an error similar to the following in the log file:
10/10/2008 9:15:23 AM CSession::Logon Error -2147221233 This information service is not installed on your computer. To install it, use the Mail And Fax icon in the Control Panel. - MAPI_E_NOT_FOUND (MAPI 1.0) Low level error: 0x2 File: 'aeMAPIProfile.cpp' Line: '120'
Cause 1:
This may be caused by an invalid config.ini file entry.
Cause 2:
This error may cause by invalid Exchange MAPI CDO.
Resolution for cause 1:
-Please check the config.ini file that is located in the same folder as the agent:
For Example: \\server_name\qmmex$server_name$\mail target agent\config.ini
-Make a backup of this file.
-Then open the original and look for a line that begins with "Exchdllspath=". If there is anything after the equals sign, remove it so the line appears as follows:
ExchDllsPath=
-Restart the agent in question and confirm that the agent is now able to log on. If this is successful, repeat for all Exchange agents on that server.
Please note: This change will persist even after a "commit changes" - you only need to make it once.
Resolution for cause 2:
-Please make sure the correct Exchange MAPI CDO is install. Latest Exchange MAPI CDO can be found at the below link:
http://www.microsoft.com/en-ie/download/details.aspx?id=36771
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