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SQL Server workload metrics stop populating in Global View
Description
For some SQL Server agents, the Workload metrics stop displaying on the Global View dashboard after collections have been running for some time. This condition remains until agent is Deactivated / Activated.
The following error can be seen in the agent log:
WARN [AGENTNAME-lowPriorityPool-1-[DBSS_Wait_Statistics][]] com.quest.glue.core.comms.filters.StaleDataFilter - Discarding sample ee88653b-88ce-4aa4-a919-1934f2c50d8c timestamped at MMM DD, YYYY HH:MM:SS AM CDT because it is 1 hour 0 minutes 11 seconds older than the server's current time and will be rejected anyway. The data sample was submitted by DB_SQL_Server/5.9.7.10/DB_SQL_Server/AGENTNAME on [MTP Agent - HOSTNAME/IPADDRESS].
Cause
The DBSS_Wait_Statistics collection could not run on schedule due to the lack of the low priority threads which are in charge of running some collections, such as 'DBSS_Wait_Statistics' collection. As a result, the DBSS_Wait_Statistics may read the old data from the cache which is populated by the PI engine more than one hour ago and it then uses PI records' sample_endtime as the submission time. So FglAM will discard these metrics because they are old.
Resolution
Increase the number of threads in low priority threads pool from the default 2 to 4.
Navigate to Administration | Agents | Agent Status
Edit the properties for the database agent
Select the link to Modify the properties for all DB_SQL_Server agents
Increase The number of threads in low priority threads pool from 2 to 4
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