This article is a complementary article to the already existing solution #SOL78784 "NetVault service/processes will not start" which should also be checked.
NetVault service fails to start.
Trace shows NetVault fails to get shared memory:
2 SHM ??? 8940 26 0 141357704276 Create shared memory 'Global\NetVault_SharedMemory_EXCHANGE_0'
5 SHM ??? 8940 8 0 141357704276 shared memory name is already in use
5 SHM ??? 8940 10 0 141357704276 FALSE = ShmAllocate(0x00445CD0, 2048000)
0 PMGR ??? 8940 27 0 141357704276 failed to get shared memory for process manager
6 SYSTEM ??? 8940 20 0 141357704276 Logging 'Process 'nvpmgr' failed to get shared memory' to system logs
3 PMGR ??? 8940 35 0 141357704276 PmgrInitSharedMem return FALSE
0 PMGR ??? 8940 158 0 141357704276 Failed to initialize shared memory
2 PMGR ??? 8940 146 0 141357704276 FALSE = PmgrInitialize()
0 PMGR ??? 8940 2 1 141357704276 Failed to initialize giveup
5 PROCESS ??? 8940 13 0 141357704276 ProcCleanup(1)
In order to successfully start the NetVault application, the NetVault parent process called NVPMGR (NetVault Process Manager) needs to be able to start.
In turn for NVPMGR to remain started the following must apply:
- NVPMGR must be able to successfully allocate shared memory for its process table which will be used to start and communicate with the other necessary Start of the Day (SOD) processes.
- Each SOD process must successfully start and remain started.
Hence when NVPMGR fails to start it could be due to:
- Failure to allocate Shared Memory to start the SOD processes
- OR if shared memory was successfully allocated a SOD process has encountered a problem.
The best way to determine why NVPMGR cannot start is to enable trace and have it examined by Support:
- run nvconfigurator > General > check "Generate debugging files" > Apply
- try to start NVBU using the nvconfigurator > Service tab or ../netvault/bin/nvpmgr startup command in CLI.
- once the service fails to start send a zipped copy of the ../netvault/trace folder to Quest Support for them to identify the cause.
In the case of a failure to allocate shared memory, this could be due to the fact that the application had not been shutdown in a clean way, leaving orphaned nv processes.
These will occupy the share memory area on behalf of NetVault and prevent NVPMGR from allocating shared memory once again.
On Unix based Operating Systems type the following in a Terminal session:
ps -ef | grep nv [OR ps -aux | grep nv for MAC]
This will list all started NetVault processes as they all start with nv*.
[On Windows the use of the Task Manager would be enough.]
If the NetVault service doesn't start and you notice that there are few nv* processes returned by this command, and NVPMGRis missing, then this means the application has not exited in a clean manner (crashed)
and the NVPMGR was shutdown leaving other child nv processes lingering, commonly known as Zombies.
To resolve this you will have to kill them:
1) Open a Terminal Session or Command Line
2) type: ps -ef | grep nv [OR ps -aux for MAC] [OR Open the Windows Task Manager and look for nv* processes]
3) This will list all nv* process that could have been left following a unclean shutdown of the application
4) Kill them as follows:
kill -9 PID [where PID is a number corresponding to the nvprocess id shown on the result of the ps -ef]
For Windows just right click on the processes in the Task Manager and select 'end process'
5) restart NetVault with : 'nvpmgr startup' [can be invoked from the ~netvault/bin directory if the above command isn't recognized.]
If NetVault is still not operational after this, then trace will reveal the culprit.
Additionally you may want to look at SOL78784 "NetVault service/processes will not start" for other recommendations.
Additionaly, check the following:
1. No anti-virus or firewall blocking the netvault services
2. No permission issue running the NetVault Process Manager service.
If all fails, re-install the NetVault client but ensure that NetVault Backup database has been backed up.
BakBone SFDC Solution Number: 00002951