Date - May 2008
Affected Product & Version - NVBU 8.0
Affected Module & Version - APM for Oracle (Version 5.5)
OS Version - any
Application Information - Oracle 10.0.2.x
Symptoms:
When running a complete recovery from within the NetVault GUI the job fails with RMAN-06054
From the NetVault log:
Information 2008/05/14 13:19:56 680 Data Plugin orarac1 RMAN-00571:
===========================================================
Information 2008/05/14 13:19:56 680 Data Plugin orarac1 RMAN-00569:
=============== ERROR MESSAGE STACK FOLLOWS ===============
Information 2008/05/14 13:19:56 680 Data Plugin orarac1 RMAN-00571:
===========================================================
Information 2008/05/14 13:19:56 680 Data Plugin orarac1 RMAN-03002:
failure of recover command at 05/14/2008 13:19:56
Information 2008/05/14 13:19:56 680 Data Plugin orarac1 RMAN-06054: media recovery requesting unknown log: thread 1 seq 4 lowscn 1301246
Information 2008/05/14 13:19:56 680 Data Plugin orarac1 Recovery Manager complete.
Warning 2008/05/14 13:19:57 680 Data Plugin orarac1 Failed with exit code 1
Error 2008/05/14 13:19:57 680 Data Plugin orarac1 RMAN returned exit code 1
Error 2008/05/14 13:19:57 680 Jobs orarac1 Fatal error: Restore failed
There are two options to resolve this:
1) perform an "alter database open resetlogs"
or
2 a) Change the restore job to run an SCN based recovery and use the most up-to-date SCN.
2 b) Re-run the restore.
These will in fact both give the same end result.
Explanation:
This problem occurs in a Disaster Recovery situation where the Online Redo logs have been lost. During the recovery process, RMAN looks in both the archived redo logs and the online redo logs for transactions to roll forward, but in this case there are transactions in the online redo logs which have not yet been archived and therefore cannot be recovered.
Oracle Error text:
Oracle Error : RMAN-06054
media recovery requesting unknown log: thread string seq string lowscn string
Cause
Media recovery is requesting a log whose existence is not recorded in the recovery catalog or control file.
Action
If a copy of the log is available, then add it to the recovery catalog and/or control file via a CATALOG command and then retry the RECOVER command. If not, then a point in time recovery up to the missing log is the only alternative and database can be opened using ALTER DATABASE OPEN RESETLOGS command.
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