A "0x800706ba : RPC Server is Unavailable" error is encountered when trying to add a new Operating System (OS) connection or validating an existing OS connection.
Could not connect to 192.168.0.1 or MYSERVER. RPC Server Unavailable (0x800706ba). The computer did not respond at all. This could be because there is a firewall blocking communication, or because WMI is not enabled on the computer. See the link below for more information on correcting the error.
CAUSE #1
This error is normally caused by firewall. RPC Server Unavailable generally means that the FglAM was able to connect on ports 135/445 but the ephemeral port connection back to the FglAM server was not successful. Windows RPC connections initially connect on 135/445 and the server being called randomly selects a port above 1024 to connect back to the FglAM server, it is this connection back that is not successful.
CAUSE #2
RPC service or remote registry service on the monitored host is not running
CAUSE #3
This issue can also occur if a NAT is in place. Windows RPC/DCOM connections are have problems NAT'ed connections.
CAUSE #4
Time sync between the Agent Manager and the Monitored Host
CAUSE #5
The issue can occur if there is an IPSec setting that only allows connections to the monitored from designated hosts.
SOLUTION #1 * This is the most common cause *
DCOM connections for WMI use a range of dynamic ports detailed here. For easier configuration we recommend using a single fixed static port for DCOM/WMI port monitoring as described in KB 4289831.
Since the agent connects remotely (that is, from an external source) the Windows Firewall can interfere with operations. In such cases, it is recommended that you initially try disabling the firewall to determine if that allows the agent to connect. When the agent can connect with the firewall disabled, re-enable it and open the following ports:
On the monitored host, enable the Inbound rule for Remote Administration (RPC), Windows Management Instrumentation (WMI), or Remote Service Management (RPC)
Windows XP/Server 2003:
Windows 7 / Server 2008:
SOLUTION #2
On the monitored host, start the RPC service and remote registry service in the Windows services console.
Please see Microsoft article "How to configure RPC dynamic port allocation to work with firewalls" at https://support.microsoft.com/en-us/kb/154596
SOLUTION #3
Move the FglAM server to the same side of the NAT device as the server being discovered to avoid the NAT altogether.
SOLUTION #4
Verify that the Time on the Monitored Host is the same as the Agent Manager.
SOLUTION #5
Revise the IPSec setting so that connections can be made from the FglAM host to the monitored host.
Microsoft Technet "Troubleshooting The RPC Server is available"
http://social.technet.microsoft.com/wiki/contents/articles/4494.troubleshooting-the-rpc-server-is-unavailable.aspx
Here is some information on the ports for the WMI from our Agent Manager installation guide that should provide further information on the ports required for WMI.
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