There is no mail synchronization, only calendar sync
CSA keeps deleting mailboxes in a loop, the following entries can be seen in the log:
1/11/2011 1:11:11 PM CExchAdmin::DeleteMailboxE2K TraceMsg 4700 Deleting mailbox '/o=OrgName/ou=Exchange Administrative Group (FYDIBOHF23SPDLT)/cn=Recipients/cn=MailboxName'.Hard delete.
CAUSE 1
FBSA (Free/Busy Synchronization Agent) running in parallel to CSA
This causes mailboxes to be recreated by Exchange 2010
CAUSE 2
Due to Exchange 2010 design, existing mailboxes need to be deleted by the agent (allowed if target mailbox is less than 100KB is size).
The CSA will first delete the mailbox, but begin working with this mailbox only during the next sesion (this is by design, due to Exchange 2010 not allowing to create a new mailbox immediately after deleting it).
Latency between 2 calendar synchronization cycles gives Exchange 2010 enough time to re-create deleted mailboxes
WORKAROUND 1
Stop FBSA, if it's running in parallel to CSA.
WORKAROUND 2
- Stop the calendar agent
- Rename or delete the log
- Disable all calendar sync collections
- Create one temp collection and move the affected mailboxes into this collection
- Perform a full resync for this collection
- Commit changes (very important)
- Start the CSA
WORKAROUND 3
When beginning with calendar synchronization, create a collection with a small number of mailboxes. Alternatively, create a few small collections and enable them one by one, to ensure that the interval between CSA session is short and Exchange will not have enough time to re-create the mailboxes.
Once all mailboxes have been deleted and re-created by CSA, the amount and size of the collections will not matter anymore and larger collections can be used again.
© 2024 Quest Software Inc. ALL RIGHTS RESERVED. Nutzungsbedingungen Datenschutz Cookie Preference Center