Microsoft Update for certain KB Article was installed but it didn't list in the "Patches Reported Installed in Software Inventory" of the device's inventory.
原因
Some of the Microsoft Security Updates and the behaviour of Microsoft Operating System doesn't display any Windows Updates in WMIC, which causes the KACE Agent unable to retrieve the Windows Update details for that device.
解决办法
Possible workaround by using AppWiz.cpl or go to Control Panel | Programs | Program and Features | Installed Updates > Do a Search to find the Installed Patches name or Windows Security Update or the KB Article No.