Time 'out of sync' issue when APM is configured using ESX hosts
说明
Two webservers are configured on different ESX hosts and the APM (Application Performance Monitoring) appliance is deployed on each of the ESX servers. However, one of the two EUM appliances is becoming out of sync with the Foglight server (FMS).
原因
Time on the ESX hosts are not in sync.
解决办法
Perform the following actions in order to help resolve this problem:
Log in to VMware host via vSphere client. Select the ESX host on the left panel.
Click the configuration tab (on the right window) | click properties on the top right corner | Click options button on the dialog box which appears
In the General tab, select Startup Policy as Start automatically if any ports are open, and stop when all ports are closed. Click Restart and click ok
Now select "NTP Settings" on the left pane, add the NTP server, click "Add" button and give the IP address or domain name of the NTP server and click OK
Select the check box, Restart NTP service to apply changes and click OK. Now, click the check box, NTP Client Enabled
Now the ESX host gets IP address from the NTP server. After obtaining an IP from the NTP server, the time needs to be synced between the ESX host and VMs. Within the vSphere client, right click on any of the virtual machines and click edit settings. This will open up the properties of virtual machine.
Here, select the Options Tab. Click on VMware Tools on the left pane. On the right pane select the check box, Synchronize guest time with host. Now the virtual machine obtains the time from the ESX host machine.
其他信息
There is no way to set NTP Server IPs for our virtual APM Appliance images . You only want to be setting NTP Servers at the physical host level.