Lineage Not Displaying After Restart or Smart Connector Execution
说明
No Lineage displayed in Metadata Manager after Tomcat restart or significant mapping updates (such as Smart Connector execution).
原因
Lineage is not persisted when DI Suite is restarted and needs to be regenerated when mapping updates are triggered. In both cases, lineage will not be displayed until background processes have completed. The update process can take hours to complete depending on the size of the DI Suite environment.
Affected Versions: DI Suite v13.0, 13.1, 13.2 GA versions
解决办法
Ensure your DI Suite environment has one of the following patches applied:
13.0.1 Patch - to be applied on 13.0 GA only 13.1.10 Patch - to be applied on 13.1 GA only 13.2.1 Patch - to be applied on 13.2 GA only
These can be requested through support at support.quest.com if needed.
***Note that all newer patch versions include these changes. If your version is higher than the one listed, no need to take action.
其他信息
After deploying the patch, lineage will not be immediately available. Some time will be needed to recreate the lineage using updated architecture. However, the UI should now display that background processes is in progress and display the lineage once created. The patch should greatly minimize the times lineage is unavailable. (Subsequently, lineage should only be unavailable when the system is actively recreating it due to updates/ Smart Connector execution and should alert end users background processes are in progress.)