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Error, "Driver not capable" or "The Btrieve file directory is invalid" when trying to connect to a Pervasive Database via ODBC
Description
When trying to connect to a Pervasive Database via ODBC, the following errors may occur
"[Pervasive][ODBC Client Interface][LNA][Pervasive][ODBC Engine Interface] Driver not capable"
or
"[Pervasive][ODBC Client Interface][LNA][Pervasive][ODBC Engine Interface][Data Record Manager]The Btrieve file directory is invalid(Btrieve Error 35)"
The ODBC driver is ODBC 3.x compliant
Cause
Connection is being made, but the errors occur when Toad is populating the Object Explorer. Not all ODBC drivers work in the same way and this ODBC driver requires special coding for Toad Data Point to support it.
Resolution
WORKAROUND:
None.
STATUS:
Enhancement request QAT-7514 has been submitted to Development for consideration in a future release of Toad Data Point.
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Toad Data Point
Topic(s):
Technical Solutions
Article History:
Created on: 4/8/2010 Last Update on: 5/7/2023
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
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