Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
Caused by: java.net.BindException: Address already in use
Description
I am trying to start a second Central Agent on the same server and below is the error message that I am getting with Stat 5.8.0 agent:
Caused by: java.net.BindException: Address already in use
Cause
Http port 8080 has been taken by the first agent.
Resolution
The above message indicates that you are trying to use a default port that is already in-use. Make sure to read the upgrade guide pg 17-18 of how to use different offset. For example, if you want to use port 8081 then you need to change this:
1. Go to <STAT_HOME>/app/bin/standalone.conf. 2. Search for the setting -Djboss.socket.binding.port-offset=0 3. Change the setting to a proper offset. For example: -Djboss.socket.binding.port-offset=1 4. Save the page
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Recommended Content
Product(s):
Stat
6.3, 6.2
Topic(s):
Configuration
Article History:
Created on: 5/9/2016 Last Update on: 10/31/2024
Thank you for your feedback for Topic Request
Your Request will be reviewed by our technical reviewer team and, if approved, will be added as a Topic in our Knowledgebase.
Welcome to Quest Support
You can find online support help for Quest *product* on an affiliate support site. Click continue to be directed to the correct support content and assistance for *product*.
Search All Articles
IE 8, 9, & 10 No longer supported
The Quest Software Portal no longer supports IE8, 9, & 10 and it is recommended to upgrade your browser to the latest version of Internet Explorer or Chrome.