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Win32 Api Failed Exception: Failed to get the size
Description
Backups fail with a similar error:
Volume transfer network error Network error during transfer of data from volume: Win32 Api Failed Exception: Failed to get the size of '\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy37' - The device is not ready Replay.Core.Implementation.Transfer.VolumeDataReaderStream.ProcessIoRequestsWithQueueing(Int32 initialQueueSize) at Replay.Core.Implementation.Transfer.VolumeDataReaderStream.b__0() at System.Threading.Tasks.Task.Execute()<--- ---> (Inner Exception #5) Replay.Core.Contracts.Transfer.CoreVolumeTransferNetworkErrorException: Network error during transfer of data from volume ---> Replay.Common.Contracts.Win32Api.Win32ApiFailedException: Failed to get the size of '\?\GLOBALROOT\Device\HarddiskVolumeShadowCopy37' - The device is not ready at Replay.Common.Implementation.Win32Api.NativeMethods.ThrowLastError(String message, Object[] args) at Replay.Common.Implementation.Win32Api.NativeIOReader.GetFileSize() at Replay.Agent.Implementation.Transfer.TransferDataConnection.HandleReque
Cause
This error is caused by the shadow copy on the agent server being deleting prior to the AppAssure/Rapid Recovery backup completing successfully.
Resolution
To resolve this issue please increase the shadow copy storage limit for the failing volume. The simplest method is to remove the limitation by setting it to no limit. To do this:
Remote to the agent system and open My Computer
Right-click on the drive that is failing, choose “Configure Shadow Copies”
Highlight the failing drive and click the “Settings” button
Choose the “No limit” radio button
Click OK to save the setting.
Click OK again to close the Shadow Copies dialogue box
Restart the AppAssure/Rapid Recovery Agent
Restart Shadow Copy Services
Once the setting has been changed, force a new snapshot of the agent.
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