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How to remove a device in On Demand Active Directory.
원인
The device needs to be cleaned up from ODMAD.
해결 방안
To remove a device in ODMAD, follow the below steps:
Uninstall the ODM Device agent.
Delete the Quest Registry key:
HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Quest\On Demand Migration For Active Directory\ODMAD_AD
Delete the Quest Folder:
C:\Program Files (x86)\Quest\On Demand Migration Active Directory Agent
Move the device object outside the environment discovery scope (Ex. CN=Computers).
Go to the Ready Devices list, select the Device to delete and in the dropdown menu select the option 'Status Resets'
Select Registration, and Apply.
Run a read workflow with 'Reconcile on Next Read' enabled for the environment/s.
Check that the device is deleted. It should no longer appear in the environment's devices list, or in the ready/not ready devices list.
If you need to bring back the device into ODM, follow the below steps:
Move the device object inside the environment discovery scope (Ex. CN=Computers).
Run an environment discovery.
Run a read and matching workflow.
The device should be found in 'not ready devices' list with a clean status.
To move the device to the 'ready devices' list, re-install the device agent.
Disclaimer: Support does not provide support for problems that arise from improper modification of the registry. The Windows registry contains information critical to your computer and applications. Make sure you back up the registry before modifying it. For more information on the Windows Registry Editor and how to back up and restore it, refer to Microsoft Article ID 256986 “Description of the Microsoft Windows registry” at Microsoft Support.