Submitting forms on the support site are temporary unavailable for schedule maintenance. If you need immediate assistance please contact technical support. We apologize for the inconvenience.
MAGE - Error System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding. (4258494)
MAGE - Error System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding.
설명
The Mage agent fails with this error in the log "Error System.Data.SqlClient.SqlException: Timeout expired. The timeout period elapsed prior to completion of the operation or the server is not responding."
원인
The agent fails to receive a response from the Migration Manager project database on the Microsoft SQL server, because the current operation has timed out.
해결 방안
1. Check PING times between the agent host server and SQL server, noting the percentage of packet loss and whether the remote host responds. 2. Check DNS (FQDN) name resolution and try resolving the SQL Server name using NSLOOKUP and PING with the -a option. 3. Review the Windows event logs on the SQL server for errors and/or warnings. 4. Check that all required services are started and running on the SQL server. 5. Check the overall load on the server by reviewing the system monitor. 6. Run a basic query (SELECT, DELETE, etc.) and note the time it takes for the server to execute it. If the operation takes very long, check if the server is overloaded.