Core unable to communicate with license portal due to missing agent registry key
説明
When attempting to communicate with License portal the Core gives error message failed to connect and in the Rapid Recovery logs the error below is shown.
System.ArgumentNullException: String reference not set to an instance of a String. Parameter name: s Server stack trace: at ServiceHost.InMemoryHosting.InMemoryServiceHost.InvokeServiceMethod[T](String managementService, String method, IEnumerable`1 parameters) at ServiceHost.InMemoryHosting.CrossDomainCall.Call() at System.Runtime.Remoting.Messaging.StackBuilderSink._PrivateProcessMessage(IntPtr md, Object[] args, Object server, Object[]& outArgs) at System.Runtime.Remoting.Messaging.StackBuilderSink.SyncProcessMessage(IMessage msg)
原因
The agent ProtectionTimestamp is missing in the registry Computer\HKEY_LOCAL_MACHINE\SOFTWARE\AppRecovery\Core\Agents\AGENTID\ProtectionTimeStamp
対策
. In order to fix this follow these steps:
Shutdown Core
Open regedit
Remove agent that is missing "ProtectionTimestamp key
Start the core services
Add agent back into protection
If the affected agent is a replica on a target core do the following:
Remove the agent from replication keeping the recovery points on the target core
Remove the agent from replication in the source core
Stop the target core service
Remove agent that is missing "ProtectionTimestamp key